Internet is connected nothing loads except Google websites

Status
Not open for further replies.

andrewpws

Reputable
Jun 10, 2014
5
0
4,510
0
My internet is connected and works. No web pages work except Google YouTube facebook. Steam doesn't work either I can only chat my friends on steam. I reset my router I've tried netsh ipv4 commands tried dnsflush commands, my ipv4 and 6 settings are on automatic. Please help I can't fix my internet!
 

andrewpws

Reputable
Jun 10, 2014
5
0
4,510
0
Little more info: wired connection, I have scanned for viruses, I cannot load or download anything on my computer because of no internet so I typed this on my tablet
 
you want to look for malware with something like malwarebytes but if you can not get the internet it is going to be tough.

Try to ping some of the other sites from a command prompt. Some sites do not respond but the main thing is that is looks the site up. You can also try the nslookup command see what you get for
nslookup tomshardware.com
then try
nslookup tomshardware.com 8.8.8.8

The second is using google dns.

If these have trouble I would be looking for firewall rules blocking you or maybe some bad stuff in the host file. You can just delete the host file exactly where it is kept varies a bit on windows release but it is just a file called hosts generally in the main system path in a directory that has a name etc.

If the DNS resolves correctly then I would be checking browser settings...maybe proxy or something.
 

eldapeeze

Honorable
Dec 23, 2012
135
0
10,710
8
Does your router have outdated firmware? It sounds almost like a DNS problem. Can you ping IP address, without typing in the DNS name? Does your router have some type of access list enabled?
 

Einston

Reputable
Sep 17, 2014
1
0
4,510
0


Hi..
Follow these steps to troubleshoot the problem:
1) Reset your TCP-IP stack from command Prompt
2) Make sure your DNS servers are correct
3) Make sure your hosts file is not altered in a bad way.
4) If you have Avast Antivirus, Disable the web shield and try again. If this is the cause, uninstall the webshield or perhaps try to remove port 80 from the redirect list under "Troubleshooting" in Avast settings
5) if still not working, reboot to safe mode with networking and try again. If it works here, run msconfig and disable all services except microsoft services and also all startup items. Reboot to normal windows, and try again. If it works now, check if your antivirus is running with the altered settings of msconfig. If your antivirus is not running (some can be disabled by msconfig but others refuse) turn your antivirus back on and reboot. Now all your startup items is dasabled except the antivirus.
6) If it works in this state, we know the antivirus is causing the problem. I suggest uninstalling your antivirus, and re-enable the disabled items in msconfig. Reboot and test without antivirus installed. If it is working, you could try to reinstall your antivirus and check if it is still working.

My problem was the Avast Web shield.
 

MrLotter

Reputable
Dec 7, 2014
1
0
4,510
0
I came across this thread, because I was having the same problem after a fresh installation of Windows 7 64-bit. I was worried because IPv6 had no connection (that's not the problem) and then that my DNS had no suffix (not the problem either). I tried EVERYTHING I found in forums including dnsflush and custom DNS servers, but nothing worked.

I then saw one mention of someone having installed 32-bit drivers and not 64-bit drivers. I tried 64-bit drivers and this completely solved my problem. It's weird how something like that would be able to do this, but that's how I solved my problem 100%.
 

Harshad Sheth

Reputable
Mar 1, 2015
1
0
4,510
0


I had the same problem. I just solved the problem.

It has to do with IPv4 and IPv6 protocols Internet connectivity. Most likely your network adapter does not have Internet connectivity for IPv4. Google has an IPv6 address, so you are able to connect. The most other sites have IPv4 addresses.

To resolve your problem, try the following in Windows 7:

Control Panel
Network and Internet
Network Sharing Center
Change Adapter Settings
Double Click on your adapter, either Local Area Connection or Wireless Network Connection as the case may be.

You probably will see:

Internet only in IPv6 Connectivity
Click on Disable button
Your adapter will be disabled
Again double click on your adapter

Your adapter will be enabled and this time it will show Internet Connectivity in both IPv4 and IPv6.

Now, you should be able to access all websites.

Good luck!







 

hoyoyi

Reputable
Mar 10, 2015
1
0
4,510
0


Hi, I have the same issue as you yesterday. And I resolved it today. It was the default getway with no key in 192.168.0.1

Open Network and Sharing Center
Connections: Wireless network connection
Property
Internet Protocol Version 4 (TCP/IPv4)
key in your default getway

ENJOY SURFING!





 

Zworba

Reputable
Apr 9, 2015
1
0
4,510
0
Hello, this problem has been bugging me for some days now and i fixed it in short by uninstalling my network driver.

My problem was caused by automatically letting it configure my router settings. When it searched for available networks after the reinstall i noticed wiifree network was highlighted. So i guess he most have connected to the wiifree net instead of the normal network SSID when it configured automatically. It makes sense now and i hope it helps anyone with this same frustrating problem!
 

vamsri

Reputable
Apr 27, 2015
1
0
4,510
0
probably, you have installed some software before facing this problem,
plz uninstall the software, if u installed any recently.and later plz restart ur pc forcefully, so that system background application will close.
and just check now...

if it is not working. problem may be with you system files.
 

atn_prabhu

Reputable
May 30, 2015
1
0
4,510
0
I had similar issue. Please check your wi-fi router's MTU setting. Router Admin page > Network > WAN > Advanced > MTU Size (in bytes). This could be different for your router

I hooked up my new router TP-LINK TL-WR841N to broadband (BSNL).

Internet access was working great in
1. One of my laptops with Windows 8.1 OS
2. My Android mobile (Redmi 1S)

But I was facing this peculiar issue of only Google, YouTube (IPv6) sites opening while all other sites (IPv4) not opening in
1. one Windows 7 laptop
2. Nokia Lumia 520

After trying every solution suggested in this forum, I finally hit one site, that suggested changing the MTU in router. My router's default MTU setting was 1480, which I changed to 1430. Voila! the issue is resolved.
 

Eliyabongili

Reputable
Jun 13, 2015
2
0
4,510
0


 

randomangel

Reputable
Jun 23, 2015
1
0
4,510
0
After days of struggling with this issue, I finally found the trivial culprit! Windows Firewall settings!

Issue explanation:
At unpredictable times, my internet connection simply stopped working for domains that were not google related!
- After reboot the internet connection worked normally again. But sooner or later, the issue started again until next reboot.
- It was no DNS problem as neither urls nor ip addresses (except for google ones) worked!

Solution:
Go to Control Panel -> System and Security -> Windows Firewall
If it says that Windows Firewall is not running with recommended settings, then be happy! Your problem is the same as mine! Simply click Use Recommended Settings and you are good to go. Internet will work as it should.

But the problem could happen again from time to time. For no apparent reason, my Window Firewall settings revert back to the Not Recommended ones and bum! Only Google sites again! Of course you could do the above again to fix it. But who is causing this problem in the first place? I started having the issue approximately when I changed my antivirus software (removing Avira and installing Kaspersky), so I guess there is some sort of remaining Firewall editing software remaining from Avira but I'm not sure yet... I just wanted to share the solution with others! :)
 

Ram Gadde

Reputable
Jun 28, 2015
1
0
4,510
0


For me, changing the DNS to Google DNS solved the problem.
Google DNS is 8.8.8.8 or 8.8.4.4. You can change DNS number in the modem/router settings or your own device on which you are connected to internet. If its your own modem/router better change it there. If it is public network where you don't have access to modem/router settings, you can change the DNS in your device for that particular connection.
 

Sid_N

Reputable
Mar 11, 2014
1
0
4,510
0


Thanks for this RandomAngel!!
Was diving in too deep into the network configuration looking for a solution, but this did it for me.

The Windows Fiewall was NOT enabled.
I enabled it, then accessed the same page I've been trying to load after each test.
This time it came up - along with this forum page :p
 

Onur Buken

Reputable
Aug 17, 2015
3
0
4,510
0


dude i just uninstalled my antivirus software and everything back to normal try that.

-sorry for my english if i wrote antrhing wrong :)
 

piyush2601

Reputable
Mar 2, 2014
48
0
4,530
0
i just fixed this issue happened with me by changing my dns with googles dns 8 . 8 . 8 . 8 in ipv4 dns server address and alternative dns server left blank
 

theboina

Reputable
Feb 11, 2016
1
0
4,510
0
Thanks!!! We changed Router MTU from 1500 to 1430 and then works fine.

You have a beer in spain when U like

Thanks!




 

Malsebrough

Commendable
Feb 21, 2016
1
0
1,510
0


Looks like there are multiple potential causes of this issue. The cause I found in my situation isn't documented in the thread yet, so I'm adding it here.

In troubleshooting a router via phone with Netgear, at some point they had me change my computer to a static IP address - in this case 192.168.1.20. After moving on through lots of other issues (including bricking the router when following the tech reps instructions, replacement coming on them), I completely forgot about this changed setting.

Just as you noted above, I could get to Google sites including YouTube, and to Facebook, but not to other websites. And like you, I could nslookup tomshardware.com, but not nslookup tomshardware.com 8.8.8.8. As soon as I changed back to a dynamically allocated IP for my imac, all my problems went away.
 
Status
Not open for further replies.

TRENDING THREADS