Question Internet keeps disconnecting windows 10

Xelcion

Honorable
Jul 11, 2014
6
0
10,510
0
Gooddday everybody,

Since almost a year now, when i'm gaming or using my pc my internet disconnects. Sometimes I can keep gaming for 3 days without a single disconnect, and sometimes it's 10 times in an hour.

After a couple months i saw somebody talk about my internet properties in my ''Realtek PCIe GbE Family Controller'' and about the save-power mode to turn it of. Well i did and i'm still disconnecting. What i did found at advanced options is that speed & duplex (snelheid & duplex, i need to translate this from dutch) on 10 Mbps Half Duplex reduces the disconnecting by a lot. But if my computer has a good day i can just put it at automatic.

I also know that it's not my cable, cause if i run the ping thing in my Cmd it still pings back when i'm disconnected.
If i disconnect the light on my Ethernet port is turned off as well.

I do get the message '' Device PCI\VEN_10EC&DEV_8168&SUBSYS_81681849&REV_11\01000000684CE00000 requires further installation'' and i have no idea where to find this thing or how to install it.

This is all the information i have at this moment, for the people wondering i did the obvious things like restarting the pc or router, Power cycling, driver updates that kinda stuff.

I really would love some help in this, because i'm kinda getting desperate with this problem. I just want it fixes now.

Thanks for reading and helping,

Jake
 

Ralston18

Titan
Moderator
Try another known working at speed Gigabit Ethernet cable between pc and router.

Try running the built-in Windows 10 troubleshooters. The troubleshooters may find and fix something.

Message suggests a network adapter driver problem.

Download the network adapter drivers via the manufacturer's website.

Reinstall and reconfigure for your network.

What make and model router do you have? The router's logs (if available and enabled) may also help troubleshoot the disconnect problem. You will need help from the router's administrator.
 

Xelcion

Honorable
Jul 11, 2014
6
0
10,510
0
Try another known working at speed Gigabit Ethernet cable between pc and router.

Try running the built-in Windows 10 troubleshooters. The troubleshooters may find and fix something.

Message suggests a network adapter driver problem.

Download the network adapter drivers via the manufacturer's website.

Reinstall and reconfigure for your network.

What make and model router do you have? The router's logs (if available and enabled) may also help troubleshoot the disconnect problem. You will need help from the router's administrator.
It's not the cable, tried that done that. Updated the drivers multiple didn't work. Did the troubleshooters 500 times didn't work. It's not a router problem either. My phone, laptop, PS4 and all my roommates stuff has no problem with it, we even got 2 new routers in the past year and still the problem is there.
 

ASK THE COMMUNITY