Question IP Camera connected to Router LAN over POE cable not working

Sep 24, 2020
6
0
10
0
My IP camera is powered by POE cable and it doesn't work when connected to a LAN port of TP LINK TL-MR 6400 router.
I checked the LAN ports by connecting a laptop via ethernet cable and the laptop is connecting correctly to internet.

However, the same camera and cable does work correctly when connected to another router (TP-LINK TD W8970).

I would prefer to use the TL-MR 6400 if I can get the IP camera working
Any ideas?

Thanks
 

kanewolf

Titan
Moderator
My IP camera is powered by POE cable and it doesn't work when connected to a LAN port of TP LINK TL-MR 6400 router.
I checked the LAN ports by connecting a laptop via ethernet cable and the laptop is connecting correctly to internet.

However, the same camera and cable does work correctly when connected to another router (TP-LINK TD W8970).

I would prefer to use the TL-MR 6400 if I can get the IP camera working
Any ideas?

Thanks
Since NETHER of these devices are POE, I will assume you have a POE injector that is actually powering the camera.
My first suggestion is to check the IP range of the DHCP servers on the two routers. They need to be the same.
You could have an IP incompatibility between the two.
How are you determining that the cameras "doesn't work" ?
 
Sep 24, 2020
6
0
10
0
Thanks for the quick replies!

The ethernet cable comes from the exterior IP cam and then into a splitter cable, one end connecting to a power adaptor (with output of 12V - 1A) and the other part of the splitter cable goes to the router LAN port.
Please see this photo of a similar looking Splitter cable
The thing is that the exact same setup does work in the TP-LINK TD W8970 router. In any case,
is there a workaroud possible, by adding in a more suitable POE injector or some other solution?

By the way, I don't use both routers at the same time. I mean I only used the second router for testing. Thanks
 
Last edited:

kanewolf

Titan
Moderator
By the way, I don't use both routers at the same time. I mean I only used the second router for testing. Thanks
My statement about the two routers being the same, is that I am trying to determine if you have the same IP ranges defined with the two routers.
You could connect the one that works -- Grab screen shots of the LAN and DHCP config pages, then switch to the non-working router. Compare the screen caps to the config on the non-working router.
 
Sep 24, 2020
6
0
10
0
on the TL MR 6400 the
My statement about the two routers being the same, is that I am trying to determine if you have the same IP ranges defined with the two routers.
You could connect the one that works -- Grab screen shots of the LAN and DHCP config pages, then switch to the non-working router. Compare the screen caps to the config on the non-working router.
Just did that comparison, the ip ranges were the same in both routers. The only differences I noticed were that the router address ended in 0.1 in one, and the other 1.1, so I made them both the same anyway. The other difference was I made IGMP Snooping: enabled in the TL-MR 6400 router as it was like that in the other router.
Then I rebooted the 6400 router, and was looking at the android ipcam app during the reboot, and it flickered online and off again....and now a few mins later it stays online!
BUT now I can't connect to Raspberry pi, which, in the wired clients list looks to be designated as "Unknown " with IP of 192.168.0.100. Maybe it's because I changed the router address?
 
Sep 24, 2020
6
0
10
0
By the way, this is the error I get when trying to connect to the Rpi:

Code:
home$ ssh pi@raspberrypi.local
ssh_exchange_identification: read: Connection reset by peer
 
Sep 24, 2020
6
0
10
0
Well, at least I can say that the Rpi is working fine, and that my issue must be related with conflicting IP addresses in my system. So I will start another thread about that issue, Meantime thanks for all the very helpful suggestions!
 
Sep 24, 2020
6
0
10
0
Oh, no need to open a new thread. The IP Camera and RPi are working fine now.
My solution was:

1. set the router IP to 192.168.01, SSH into the PI, then turn off with
Code:
 sudo init 0
2. turn off power supply to the Rpi

3. disconnect IP Cam and RPi cables from router LAN ports.

4. after some minutes (maybe 20 mins) I turned on power supply to Rpi

5. reconnect the ethernet cables for IP camera and Rpi to router LAN ports


All those steps were not necessarily in the exact above order....just from memory.
In any case, everything looks normal now in the router LAN settings clients lists.

Thanks again for the invaluable help!
 

ASK THE COMMUNITY

TRENDING THREADS