Question Is my 2080ti working properly?

Oct 8, 2020
4
0
10
0
I recently got a used 2080ti off of reddit. I'm not sure if it's working properly. There is a bit of ran noise at 60%-63%, higher than that and it disappears. The noise doesn't bother me so much, the possibly lack of performance does however. I was upgrading from a 1070, and I feel I've only seen slight improvements. I got this 2080ti because I wanted an ultrawide monitor and it wasn't as smooth with the 1070. I really couldn't justify the extra 200$ with tax and what not that i'd pay for a 3080, and didnt think i'd need the performance increase ( im seeing the issue buying used)

Sorry for all of that background.

anyway, I was digging further after the fan noise and some lower than expect fps in games, and saw im getting pretty low benchmark scoes. I got a 2900 in uniengine heavean, where similar builds were getting around twice that.

Sorry for being a bit of a novice. I'd like help doing research before I start demanding a refund from the guy I purchased the card from.
 
Oct 8, 2020
4
0
10
0
Well, I did as you suggested and it seemed to bump a bit. I'm not quite sure where I should be, though.

Here is after your suggestion

file:///C:/Users/beaud/Unigine_Heaven_Benchmark_4.0_20201008_0245.html
oops that was the original,
here is the other one
file:///C:/Users/beaud/Unigine_Heaven_Benchmark_4.0_20201008_0345.html

MSI VENTUS 2080TI
8700K, not really overlocked just set to "fast tuning" in the bios
64gb 3200mhz Corsair Vengeance RGB pro (I didn't think i needed so much, but it was on sale)
Z370-E
850 EVO 500GB ssd
970 EVO PLUS 1 tb
 

ASK THE COMMUNITY