Question Is my gpu faulty or my mobo? Cant seem to find the answer

Apr 17, 2019
3
0
10
0
My gpu repeatedly crash and recovered. But recently it just went completely black screen and when i restart my pc it wont display anything. Also the "beep" sound come after about 30 to 60 sec, usually when i press tge power button it the "beep" come in about 5 seconds.

This problem only occur after almost 2 years i own that gpu. Can anyone help?

My pc spec:
Gtx 1060
I5 3330
H61m mobo gigabyte
550w psu
Ddr3 ram 8gb
 

ShadeSlayer812

Reputable
Dec 1, 2015
44
0
4,540
1
It sounds like the GPU. That beep sound you are hearing is a beep code. Open your MOBO manual and you should find what it means. If you have a post card, check that. If you don't, the easiest way to check would be to unplug your monitor from your gpu and plug it into your MOBO since your CPU has on board graphics.
 
Apr 17, 2019
3
0
10
0
It sounds like the GPU. That beep sound you are hearing is a beep code. Open your MOBO manual and you should find what it means. If you have a post card, check that. If you don't, the easiest way to check would be to unplug your monitor from your gpu and plug it into your MOBO since your CPU has on board graphics.
I dont have any spare gpu since i already gave it to my friend and he is living in another state.

I already try without gpu, and my pc run well. Is it hardware problem?

Or could it be mobo bios? But even without the proper bios i should have display right?
 

Similar threads


ASK THE COMMUNITY

TRENDING THREADS