Question Issue with Drivers...

RedzoneDj

Prominent
Dec 10, 2019
5
1
515
0
Hello all,

Bit of a tricky one and long but if you have the time, I would appreciate any guidance!

My beloved PC has been having a real hard time recently. Below I will list some issues that have been reoccurring and hopefully someone can help me figure out what on earth is going on!

Graphics driver randomly causes problems - Happens every couple of days or so, I boot a game and get ridiculously low FPS! I have to delete my Graphics driver and re-install a fresh one. I use Nvidea GeForce experience and opt for express installation, it performs an install but doesn't actually complete, just goes back to the "Express installation" option over and over, until I eventually perform a restart and it kicks back into normality. Sometimes when trying to re-install the driver, the PC gets stuck and the fans rev up to an insane speed that I did not even know was possible. The only option I have is to perform a hard restart. Again, PC restarts like nothing happened.

Random device disconnection - Randomly (mainly when gaming) I will here the noise that something has been disconnected from my PC. I have a feeling it's my graphics driver stopping and starting again but I cant be sure as it instantly reconnects before I can check . My keyboard also disconnects completely sometimes, forcing me to restart my PC and it starts working again.

BSoD - I get the blue screen of death randomly out of nowhere. I was remoting my PC from work, scanning for malware and viruses and it must have happened at least 5 times while I was doing it. Again, I restart when safe to do so and it's like nothing happened.

Game minimises while gaming - I play on a 4k monitor but run my games 1440p. When I click off the game, it minimises the game so the main desktop screen can render back into 4k. This is normal. But it randomly does it while I'm gaming. I don't click off the game at all but the computer for some reason thinks I have so it minimizes the game... very strange issue and only happens now and again. Not sure if it bears any relevance.

What I have done;

Created a system restore point before doing any of the following

Scanned the PC for Malware multiple times. I have ran RKILL simultaneously to ensure no malware processes would interfere with the scan. Results: No Threats

Ran Anti-Root kit software - Results: Multiple traces of spyware found in one of my 2k Game launcher files. I have since removed those files.

Ran Tron Script - Tron script has been ran but did not flag anything unusual.
(I created a restore point before running this, I have read it can potentially damage your OS so just did it to be safe)

I have mainly done these steps after finding the spyware, as you can imagine I'm insanely paranoid after finding that so took multiple measures to try and find anymore traces.

Issues I think could be causing it

  • Faulty Power supply
  • Malware / Virus - Particularly affecting my drivers.
But in truth, I have no idea...

If anyone could help me with troubleshooting these problems, It would be really helpful. I have tried to put it into words best I can, if you need anymore info please let me know!

Specs -

CPU: *AMD Ryzen 7 3700X 3.6 GHz 8-Core Processor

Motherboard: Asus ROG STRIX B450-F GAMING ATX AM4 Motherboard

Memory: Corsair Vengeance LPX 16 GB (2 x 8 GB) DDR4-3600 CL16 Memory

Storage: Crucial MX500 1 TB 2.5" Solid State Drive

Power Supply: *Corsair TXM Gold 650 W 80+ Gold Certified Semi-modular ATX Power Supply

GPU - Corsair RTX 3060TI
 

ASK THE COMMUNITY

TRENDING THREADS