Keyboard and mouse wont work in BIOS using advance startup option

Sep 2, 2018
1
0
10
0
I wanted to switch OS to windows 7 from windows 10 so I used the USB method. When I booted up my USB I got into windows installation for windows 7, however, I couldn't use my mouse or keyboard. I edited USB settings in the UEFI bios and I also heard somewhere that I should change my boot order. Due to changing my boot order my computer has the checking media presence >media present start pxE over IPv4 and then IPv6 after which my old OS (windows 10) loads perfectly fine. However I cant access the bios anymore through pressing del or f2. I can only access it when I use advanced startup options through windows. When I do this my mouse and keyboard won't work. It works perfectly fine otherwise. I've tried using a PS/2 adapter but it doesn't work at all. I've also tried resetting my bios through removing the battery but my motherboard doesn't allow me to do so. Please help I'm deperate
 

Colif

Win 10 Master
Moderator
What are specs of PC? What motherboard do you have? If its an MSI motherboard you might have ultra fast boot turned on and it could just be ignoring mouse/keyboard at boot

Have you tried other USB slots? Are mouse/kb wired or wireless?

what did you do in the UEFI USB settings? You might need to reset the CMOS and set bios to defaults


Due to changing my boot order my computer has the checking media presence >media present start pxE over IPv4 and then IPv6 after which my old OS (windows 10) loads perfectly fine.
You don't want PC checking for network drives on boot up unless you have a server you boot off?
 

karenjoly

Respectable
Apr 13, 2018
1,329
20
1,815
205
Which mainboard ? Has the user manual set out any instructions for installing Windows 7 and usb 3.0 port use ? There are reports that warn to make sure that you are using USB 2.0 ports for the mouse and keyboard. Windows 7 Setup does not know how to use USB 3.0
 

Colif

Win 10 Master
Moderator
What are specs of PC? What motherboard do you have? If its an MSI motherboard you might have ultra fast boot turned on and it could just be ignoring mouse/keyboard at boot

Have you tried other USB slots? Are mouse/kb wired or wireless?

what did you do in the UEFI USB settings? You might need to reset the CMOS and set bios to defaults


Due to changing my boot order my computer has the checking media presence >media present start pxE over IPv4 and then IPv6 after which my old OS (windows 10) loads perfectly fine.
You don't want PC checking for network drives on boot up unless you have a server you boot off?
 

ASK THE COMMUNITY

TRENDING THREADS