Keyboard keys get stuck ONLY IN GAMES!!

Status
Not open for further replies.

Coman Alexandru

Reputable
Nov 24, 2014
4
0
4,510
0
Hi.I've got a problem with my new keyboard(2 months old) Microsoft Comfort Curve 3000.
When I play any game,W and sometimes Space keys get stuck,and I have to press them again to revert them back to normal,but then they will get stuck again and so on.The thing is that in any other circumstances when I type,like browsing,notepad,word etc etc,none of the keys get stuck no matter what I do.I've also connected my tablet wirelessly as a keyboard for my PC and tried playing a gaming,and it didn't get stuck at all.Provided that the keyboard gets stuck only when playing games,I don't think that the keyboard it's broken.Also,I tried to change the USB ports with every other one i've got,but with no result.
I reinstalled my windows,Scanned it with Malawarebytes in Safe Mode and so on,but with no success.What could be the problem???

It is getting very annoying,please answer fast.Thank you!
UPDATE:My keyboard has a function that turns off Num lock Scroll lock and Caps lock lights after 5 seconds of no use,and then instantly turn them back on when I press any key on the keyboard.Well,I noticed that in games,keys get stuck only after long press,when the status lights of Caps Num etc go off,so... If I would be able to disable this function,maybe the problem will be solved,the question is.. how do I do this?
UPDATE 2 : Problem solved.It could also be the solution for the ones who have the same issue,I found out that,at least in my case,the problem was caused by the USB autosusped feature ( windows turns off the devices to save power) So here's the solution:

Go to Control Panel > Hardware and Sound > Devices and Printers

Right click on your USB Keyboard, go to Properties, then the Hardware tab.

Highlight USB Input Device (this is the part that doesn't show up under Device Manager) and click on Properties. Click on Change settings.

Go to the Power Management tab and uncheck 'Allow the computer to turn off this device to save power'
 

Proxify

Reputable
Dec 11, 2014
145
0
4,710
21
Thanks for keeping your post updated so others can find the solution. As I was reading through your post I was thinking it was suspending your usb connection somehow and it seems that you've already figured that out! Thanks for the post!
 

Proxify

Reputable
Dec 11, 2014
145
0
4,710
21
Thanks for keeping your post updated so others can find the solution. As I was reading through your post I was thinking it was suspending your usb connection somehow and it seems that you've already figured that out! Thanks for the post!
 

Bill_10

Reputable
Oct 27, 2015
1
0
4,510
0
I had this problem when I bought a brand new box but kept the old keyboard and mouse. I have a PS2 KVM switch so I can access both of my computers. I bought a lead that combines a PS2 keyboard and mouse into one USB input. The new machine has one PS2 input on it that can take either a keyboard or a mouse. When I unplugged the keyboard from the USB lead and plugged it into the PS2 input the problem went away.
 

LittleCreekHosting

Reputable
Nov 20, 2015
3
0
4,510
0
Thanks for the solution. Why did Microsoft feel the need to turn this "feature" on without telling me? All I did was upgrade from Windows 7 to Windows 10 and then all of a sudden keyboard problems for 4 days. Makes me want to go back to Linux.
 

ScepTech

Commendable
Feb 19, 2016
1
0
1,510
0


I can't find the Power Management tab.
 

harveydanger

Honorable
Aug 20, 2012
1
0
10,510
0
Yeah, unfortunately for me, that setting isn't even an option to be turned ON for my keyboard in device manager. So there's no way to turn it off, obviously.

This problem has been persistent for me ACROSS computers and keyboards. This tells me it might be one of my peripheral devices (a USB external hard drive is the only common piece of hardware that I can think of) or maybe a program that I use, but for the life of me I can't figure out which one. It's been happening to me since at least 2010 and I've never found a solution. I've tried disabling controllers in device manager, turning off sticky keys, and I even bought a Corsair K70 because it purportedly has NKRO and I thought that might solve it. Nope.

The worst part is that it only happens in certain games and nowhere else, and it's entirely unpredictable. TF2, Terraria, and Starbound are the biggest problems. Playing Devil Daggers at the moment and today it's been locking up directional movement every five minutes or so. It's just... miserable.
 

july85

Reputable
Mar 19, 2016
14
1
4,525
1
Thank you very much!!

I play CS:GO and have MS Curve 3000 - had the very same problem last 3 months and now it is solved. Thanks a lot!
 

Linkviii

Reputable
Jun 2, 2015
2
0
4,510
0
I had this problem before and the power management setting worked while on windows 10. I was bash hungry and installed the insider build which reset some settings. Now I have this problem again and I can't seem to fix it again. The power setting is now off for almost every device. (who cares about bash, I want my games back)
 

TerraT

Commendable
May 25, 2016
1
0
1,510
0


THANK YOU SO MUCH! This has been driving me CRAZY! <3
 
Status
Not open for further replies.

ASK THE COMMUNITY

TRENDING THREADS