Question Lag and choppinnes when plugging Laptop to HDMI, anyway to fix without restart ?

Oct 29, 2019
5
0
10
0
Every time I plug HDMI from my laptop to the TV or monitor with laptop already on and select the image to show in the external display only, the animations in the external display become laggy. For example the nvidia logo spinning in the nvidia control panel looks like its running at 30hz with frame skips, scrolling in browsers or folders is really choppy, it only happens in Windows, when i play games in exclusive fullscreen there is no lag, but if I switch to windowed or borderless there is lag and frame skips.

The only solution I have found is to restart the laptop with the HDMI cable already connected and the image only showing in the external display (tv/monitor), but if I switch back to the laptop screen only, choose duplicate or extended mode, and then switch back to the external display only, the lag comes back, and it's really annoying.

Duplicate mode has the reverse effect, windows seems ok, but games lock to 30 fps

Why does this happens? Is there a permanent fix for this without having to restart my laptop every time I decided to play on the tv or in the monitor?
Is there a fix for the fps drop with duplicate mode? This doesn't happen in my desktop, but in the laptop its getting really frustrating.

My Laptop is :
Acer Predator Helios 300 G3-572 i7-7700HQ GTX 1060
Windows 10 Home x64 1903
 

Lutfij

Titan
Moderator
We're currently on 1909, so perhaps that would be one thing to look at. On another note, are you on the latest BIOS update for your laptop? You might want to uninstall your Nvidia GPU drivers using DDU and then reinstall using the latest off of Nvidia's support site(installing it manually).
 
Oct 29, 2019
5
0
10
0
We're currently on 1909, so perhaps that would be one thing to look at. On another note, are you on the latest BIOS update for your laptop? You might want to uninstall your Nvidia GPU drivers using DDU and then reinstall using the latest off of Nvidia's support site(installing it manually).
I already updated Windows, but the problem persists. The laptop came with the latest bios update (v1.22)

Here is a video showing the issue I'm having:

Another temporary fix I found is to disable the Intel Gpu in device manager and re-enable it back, the problem is, I already tried with 3 different drivers, 2 old ones and the latest one available for my machine but all have the same problem, I also have the latest nvidia driver.

Restarting explorer.exe also seems to fix it but just for a few seconds.

When this laptop came I tried it first time and the problem was there, I formatted it and the problem remains.

It only happens if I select the external display as the main display. Extended Mode does not do this, but I don't want to keep the laptop screen on, Duplicate also doesn't do, but it locks to 30 fps in fullscreen.

In the video I linked the author mentions having fixed the problem with Windows update 1803, but I'm in the 1909 and without a fix. I don't know what else to do, it's really annoying.
 

ASK THE COMMUNITY

TRENDING THREADS