[SOLVED] Laptop BSOD, possibly due to Type C HUB ?

Yosef Marcera

Commendable
Oct 1, 2020
24
0
1,520
My laptop is the Lenovo Ideapad S340-14API with a Ryzen 7 3700U. I got this laptop back in 2020 and required a wired internet connection for better stability, so I got this no-brand Type-C Hub that has an RJ45 port and 3 extra USB ports, which worked perfectly fine for over 2 years until now. Recently, the ethernet connection (which is what I got the hub for in the first place) started being unstable. I noticed the laptop switching from wired to Wi-Fi every couple of seconds, which was very inconvenient for me because I use Voicemeeter Banana to relay audio to and from my laptop and desktop.

So I decided to disconnect the LAN cable and switch to Wi-Fi since I didn't want my audio to disconnect every other minute. Apart from the faulty RJ45 connection of the USB hub, the three USB ports seemed to be working perfectly fine for a couple of weeks, until I recently experienced these ports disconnecting and reconnecting at random times of the day. I use my laptop as my dedicated streaming PC, with my capture card from my gaming PC connected to the USB hub into the laptop, so I notice these reconnections as my display gets affected. And now, as the title suggests, my laptop started getting blue screens, particularly at times when I use the capture card which is connected to the USB hub. The BSOD error states "SYSTEM_ THREAD_EXCEPTION_NOT_HANDLED" with ndis.sys tagged. I did some research, and bluescreens tagged with ndis.sys may possibly be caused by external devices (which I assume are faulty), which is why I assume that my USB hub may be to blame.

I started using my laptop with the USB hub disconnected, connected the capture card directly to the laptop, and tried to stream this way. I have not encountered any issues so far, yet I lack the ports since I do not use the hub anymore. I am now considering buying a Type-C Hub from a brand known for its reliability, UGREEN. I know I could trust the brand, yet I am still having second thoughts on buying the hub since the problem may possibly lie on my laptop. Insights will be much appreciated.