Laptop can't detect own wifi, but phone can

Jul 7, 2018
2
0
10
Best answers
0
I've been connected to my wifi at home before, but it suddenly threw me off the network one day and I can't find it anymore while it can detect other wifi networks. My phone can connect just fine, as can other new devices. Meaning it isn't hidden.

I rebooted my router and laptop, I typed in the ssid manually, I reinstalled the driver, I went from "802.11b" to "802.11b/g", I changed my channel from "auto" to "20Mz Only", I reset my laptop to factory settings..

Basically, I did everything I could find online and nothing works. I really need help with this. This was an expensive laptop and I don't want to go buy another one while this one works so good (at least when it has wifi)
 

Math Geek

Glorious
Herald
Oct 15, 2014
11,664
131
49,440
Best answers
1,965
my first though is the "802.11b/g" you wrote. that is really old standard and a new laptop should be at least "n" rated if not "ac". tour router needs to be sending out a signal your laptop can see. double check and be sure the router is set to supply the same as your laptop can receive. don't know your laptop model so don't know what it can handle.

other thing i have seen issues with more than once, is where a new pc/laptop has conflicting programs all trying to manage the wifi. they end up stepping on each other and wreck havoc trying to connect.

see if you have more than one thing running other than the normal windows network manager. will probably be branded the same as the laptop if it is there. can even be a third one present from the wifi card's manufacturer as well! if so, then turn off all but the windows network manager and see what just that does for you. this has worked for me a number of times over the years.
 
Jul 7, 2018
2
0
10
Best answers
0
I found the issue.

My channel was set on 11 and while this should be a working channel, I turned it to 1 and it fixed the problem.
I wouldn't even have gone to change it if it wasn't for Math Geek's comment about the "n" and "ac" thing. Since those weren't options on my laptop. I saw the option to change the channel and decided to play around a bit. It's still 802.11b/g, just on a different channel and working perfectly ^_^ Thank you Math Geek, I'll click on the "pick as solution" just for 'inspiring' me to play with the channel settings.
 

ASK THE COMMUNITY

TRENDING THREADS