[SOLVED] Laptop keyboard input issue

koolghost

Reputable
Apr 21, 2017
21
0
4,510
0
I have an Asus Zenbook 13 UX331UAL and it is having keyboard input problems.

My keyboard suddenly started typing characters in a different language even though English was the only installed language in Windows. I made sure keyboard drivers, windows, etc everything was updated and booted in safe made, but with no luck. So I reset Windows and it stopped typing different characters but then certain keys stopped working.

I then reset windows 2 times more and random problems started with the keyboard. Sometimes it would open certain apps when pressing a key, example when i pressed C it opened cortana, F it opened feedback. Other times any random keys would stop working. I then tried using on screen keyboard and external keyboard, but even they worked correctly sometimes and sometimes behaved the exact same way as the built in keyboard.

One thing I noticed that even after disabling/uninstalling the in built keyboard via device manager, the keyboard still functioned. To sum up, any keyboard input behaves erratically.

Here is the link for the drivers page of the laptop - https://www.asus.com/in/Laptops/ASUS-ZenBook-13-UX331UAL/HelpDesk_Download/
 

Lutfij

Titan
Moderator
Which version of Windows 10 are you currently on? You might want to see if your laptop has any BIOS updates pending. You should download and install all drivers found off of Asus's product support page and manually install them in an elevated command, i.e Right click installer>Run as Administrator.
 

koolghost

Reputable
Apr 21, 2017
21
0
4,510
0
Which version of Windows 10 are you currently on? You might want to see if your laptop has any BIOS updates pending. You should download and install all drivers found off of Asus's product support page and manually install them in an elevated command, i.e Right click installer>Run as Administrator.
My windows version is 2004, OS build - 19041.450. The latest bios version and drivers are installed. Many drivers on the support page are older versions than currently installed, Windows might have updated them automatically.

Is this a hardware issue or software issue? Given other input methods don't work I think it is a software issue.
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS