Question Legion 5 Pro feels sluggish and gets low frame rates in games all of a sudden

Nov 17, 2021
2
0
10
0
Hello,

Ive been using my new Lenovo Legion 5 Pro for a few months now.
I have the intel version (i7 - 11800 , 16GB RAM, NVIDIA GeForce RTX3060)

I wanted to play some games today after a long day hower I noticed my games are running very poorly.
I tried playing battlefield 5, and just cause 3 normally I always have 60fps in battlefield v (capped) and around 140 in just cause 3.

But now im getting 15 - 30 fps in battlefield V and just cause 3 and the games are very stuttery.

Ive looked at task manager while gaming and the hardware utilisation of the cpu never goes higher than 20% around the same for the RTX 3060.
It feels like i'm gaming on battery power even tho the charger is plugged in and im in balanced mode.


Whenever I am in balanced mode, the max utilisation of the cpu and gpu is 20% when I am in performance mode it is 30%

Ive launched microsoft flight simulator and that is a very demanding game, it ran fine before.
While running MFS I noticed that the cpu and GPU utilisation never go higher than 20% in balanced or 30% in performance it is really stuttery now and unplayable

I don't know what caused this I did not change anything of my settings
 
Nov 17, 2021
2
0
10
0
Hello,

Ive been using my new Lenovo Legion 5 Pro for a few months now.
I have the intel version (i7 - 11800 , 16GB RAM, NVIDIA GeForce RTX3060)

I wanted to play some games today after a long day hower I noticed my games are running very poorly.
I tried playing battlefield 5, and just cause 3 normally I always have 60fps in battlefield v (capped) and around 140 in just cause 3.

But now im getting 15 - 30 fps in battlefield V and just cause 3 and the games are very stuttery.

Ive looked at task manager while gaming and the hardware utilisation of the cpu never goes higher than 20% around the same for the RTX 3060.
It feels like i'm gaming on battery power even tho the charger is plugged in and im in balanced mode.


Whenever I am in balanced mode, the max utilisation of the cpu and gpu is 20% when I am in performance mode it is 30%

Ive launched microsoft flight simulator and that is a very demanding game, it ran fine before.
While running MFS I noticed that the cpu and GPU utilisation never go higher than 20% in balanced or 30% in performance it is really stuttery now and unplayable

I don't know what caused this I did not change anything of my settings

To anyone having the same problem in the future (wich is probably nobody). I think it was some kind of bug in the Lenovo vantage software. I remember turning off my pc and just the split second when it was completely off I disconnected the power so it had to work on that split second on battery. Now I think it got messed up thinking when I turned it back on it was running on battery power because I had no performance change when I disconnected the power and switched to battery power.

What I did to fix it was turn off the laptop. Disconnect the power and turn it back on battery, then switch from balanced mode to silent mode and back. Turn off the laptop again, then turn it on and after that it worked fine.
 

ASK THE COMMUNITY

TRENDING THREADS