Question Lights turn on but no post.

Jan 19, 2021
3
0
10
0
I have a pc with
A ryzen 7 3700x
A xfx Rx580
Some kind of ram that is 2x8 gigs
A thermal take 600 watt smart psu.
Unsure of the rest of the spec due to the fact i got a prebuilt and didnt build it my self.
I run dual moniters. And i have been getting random crashes where my screens will turn random solid colors and the whole system freezes up. It then half the time blacks the screens and comes back up, other times it it wont turn off or do anything unless i hold the power button. Once i do this however it does not like to come back on most of the time. Most of the time the lights will come on and fans will go but no out put or orange flashing light indicating a post. After that i just end up leaving it off for a while and then it works but the amount of time it needs before it works is completely random. Temps are fine. At one point i thought this was a gpu error because i would get artifacting amd bsods saying thread stuck in device driver and other errors relating to the gpu. However i reinstalled drivers and that fixes it for awhile. I have also had my hard drive not being picked up by the system(i run a ssd for boot and a hard drive for mass storage). This is fixed by a restart but its still a issue because i cant restart without worry of it not coming back on. Im honestly at a loss so of no one on here can come up with any fixes i may just buy a whole new pc. This time made by myself lol. Thanks in advance!
 
No sadly its about 2 years old i believe it just went out of warranty as the issues started
Your issue could be related to that Thermaltake Smart PSU. It's a low quality PSU. It's a 55 dollars USD PSU.

This is what I would start with.

These pre-built cuts corner on a lot of parts to make more profits. Mostly on the RAM, drive and PSU.

When you build your system you buy fast ram and a good SSD and a good model PSU. When you buy a pre-built they give you a cheap PSU, slower RAM and sometime the cheapest SSD possible like a green model you don't want.

Not all pre-built are like this obviously but a lot of them.
 
Last edited:
Jan 19, 2021
3
0
10
0
Your issue could be related to that Thermaltake Smart PSU. It's a low quality PSU. It's a 55 dollars USD PSU.

This is what I would start with.

These pre-built cuts corner on a lot of parts to make more profits. Mostly on the RAM, drive and PSU.

When you build your system you buy fast ram and a good SSD and a good model PSU. When you buy a pre-built they give you a cheap PSU, slower RAM and sometime the cheapest SSD possible like a green model you don't want.

Not all pre-built are like this obviously but a lot of them.
Ha yeah thats exactly what i got my ssd is cheapo my ram is like 2400 speed or slower I believe and i guess my ps is also cheap. My fault for getting a prebuilt. I got lazy lol. Thanks for the advice though
 

ASK THE COMMUNITY

TRENDING THREADS