LiteOn 124 19B drive won't open or read discs


Mar 30, 2012

I've just replaced an old IDE DVD drive with a new LiteOn iHAS124 DVD+RW SATA drive.

Once installed, Windows 7 can see it and says it is working correctly but when I press the physical eject button the green LED on the drive lights but nothing else happens and when I eject it from the Computer window it comes up with an error message.
I used the manual eject (putting a pin in the hole) and inserted a DVD and the drive still appears empty in Win7.

I've got an SSD so my SATA controller is set to AHCI, but I've tried switching it back to IDE with no success.

I've uninstalled it from the device manager and re-started to re-install the drivers twice.

I've installed LiteON's Smartpack utility which recognises the device and says firmware is up to date.

I've run the windows fixit program which hasn't helped and run the "configure a device" troubeshooter which doesn't recognise a hardware change (unsurprisingly as it's installed the drivers happily enough).

I can't remember any further steps I've tried but all the other forum posts with this issue have either gone silent or been solved using one of the steps above.

Any advice would be appreciated.