Question Long time to boot via BCD menu and multiple WinOSs

AlexS

Distinguished
Jun 16, 2011
94
1
18,535
0
Hello

My previous MBR config I could boot Windows BCD menu, select and it would just boot straight into whatever Windows OS I selected.

I've got an Gigabyte Designare motherboard now, and new SSDs, so I've wiped everything and gone full UEFI. There is a single GPT partition for this and when I boot it goes to a similar menu with two Windows 10 OS options (all clean installs).

1) The first Windows option selected boots straight into windows. Fine.

2) The second Windows option when selected, the screen goes blank, it then appears to reboot, I then see the Gigabyte BIOS screen and only then does it boot into the correct Windows partition.

Is (2) normal? Can anything be done so it can boot without rebooting?

Appreciated.
 

viveknayyar007

Distinguished
Moderator
Hello

Microsoft recommends to install all the Operating Systems in their own separate partitions in a multi-boot environment. That makes difference.

If the earlier MBR disk had single partition and both the operating systems were booting normally, you can either try converting your GPT disk to MBR, or can go for the above suggestion and see if any of those helps.

Please note that converting a GPT disk to MBR needs all the volumes on the disk to be deleted.

Good Luck!!
 
Reactions: AlexS

AlexS

Distinguished
Jun 16, 2011
94
1
18,535
0
Hello

Microsoft recommends to install all the Operating Systems in their own separate partitions in a multi-boot environment. That makes difference.

If the earlier MBR disk had single partition and both the operating systems were booting normally, you can either try converting your GPT disk to MBR, or can go for the above suggestion and see if any of those helps.

Please note that converting a GPT disk to MBR needs all the volumes on the disk to be deleted.

Good Luck!!
  1. All OSs are in separate partitions.
  2. As stated new disk, clean installs, no MBR anywhere.
  3. I'm sticking with GPT and not going back to MBR, that's the point of the exercise.
My question is:

The second Windows option when selected, the screen goes blank, it then appears to reboot, I then see the Gigabyte BIOS screen and only then does it boot into the correct Windows partition. Is this normal? Can anything be done so it can boot without rebooting? (Besides going back to MBR).
 

swineadam

Prominent
Jun 21, 2018
48
3
545
1
as far as i know, this is normal. does it on my system too. i am pretty sure it has something to do with UEFI and that the OS boots from UEFI, or something to that effect. but yeah... seems normal.

if you REALLY want to avoid it...

you might have to enable legacy from Windows. at a command prompt use > bcdedit /set bootmenupolicy legacy. (default is standard) then enable Compatibility Support Module (CSM) in the UEFI/BIOS and set it for legacy.

i don't know if this will change that behavior or not, and personally prefer the faster boot times when just going to the default OS. (enabling CSM and using legacy bootloader will slow your default boot times.)

either way, you can check which BIOS mode your Windows is using by opening/running msinfo32. or, Admin tools > system info. it will say either legacy or UEFI.
 
Last edited:
Reactions: AlexS

AlexS

Distinguished
Jun 16, 2011
94
1
18,535
0
as far as i know, this is normal. does it on my system too. i am pretty sure it has something to do with UEFI and that the OS boots from UEFI, or something to that effect. but yeah... seems normal.

if you REALLY want to avoid it...

you might have to enable legacy from Windows. at a command prompt use > bcdedit /set bootmenupolicy legacy. (default is standard) then enable Compatibility Support Module (CSM) in the UEFI/BIOS and set it for legacy.

i don't know if this will change that behavior or not, and personally prefer the faster boot times when just going to the default OS. (enabling CSM and using legacy bootloader will slow your default boot times.)

either way, you can check which BIOS mode your Windows is using by opening/running msinfo32. or, Admin tools > system info. it will say either legacy or UEFI.
As stated I'm fully UEFI, 100% certain I am and sticking with it, so don't want to enable CSM. I assume Windows legacy boot mode won't work with this.

Thx for confirming this is normal behaviour, it's a bit crap. I've tried Linux grub to get around this and it will only detect one copy of Windows with GPT/UEFI partition sadly. I could try to create another UEFI partition but that would be non standard.

Cheers.
 

ASK THE COMMUNITY

TRENDING THREADS