Question Low 1% and 0.1% FPS drops but otherwise good FPS, would appreciate any help


Jun 21, 2013
I have been getting very low 1% and 0.1% FPS numbers that cause stuttering, when otherwise getting a solid 60 FPS
It's across multiple games, my 1% and 0.1% lows are like 5-25, while I can maintain an FPS at above 60 and even average FPS remains high. Thinking maybe it's something wrong the the CPU or MOBO? But I cannot buy another MOBO or CPU just to determine this.

Using MSI afterburner none of the hardware is usually even above 70% usage when this happens. (Monitoring RAM, CPU (all cores), and GPU) Temps essentially never get above 60 c.
Userbenchmark and HWinfo show my RAM clocked at different MHz though...see below. I have noticed that RAM clock doesn't go over 2000 MHz though, in game while using MSI Afterburner, would this make that big of a difference?

It tends to happen more frequently when in urban areas, or when there are multiple "people" in an area/battlefield (be it a strategy game, or RPG etc...) Although this is not always the case as it happens otherwise as well. So far I've noticed it in Assasins Creed Odyssey, Fallout 4 (vanilla and modded, though modded is somewhat worse), Total War Warhammer 2 and Arma 3. I should upload a picture of the Odyssey benchmark, it's anywhere between 90FPS and 19 on any settings. So average says around 60 but low goes to 19 the chart makes it very obvious.

CPU: i5 9600k
GPU : rx660xt 8GB
RAM: Corsair 16GB 2666Mhz Ram (it's 4000MHZ RAM, but the CPU and MOBO have it clocked at this, hwinfo also says it's running in dual channel 18-18-18-43)
Storage: 500GB nvme samsung evo 970 (OS is on this as well as the games I am trying)

Some things I've tried:
Changing power plan
Intel diagnostic for CPU
Memtest for RAM
Postponing windows updates
Using/not using Vysnc in game and with 3rd party software
Lower settings to very low, still get same issue
BIOS is up to date
GPU drivers are up to date
Have tried enabling XMP in BIOS, although this MOBO I don't think allows much of that.

Additional Info:
PC Info:
Last edited:


Jun 21, 2013
DPC latency issue maybe?

I followed most of this guide:

Couldn't find any issues