[SOLVED] m.2 SSD not showing in Disk Management (is in BIOS and Device Manager)

Dec 30, 2019
4
0
10
0
Hello All, Hoping for some assistance.
Added a second drive (m.2 NVME PCIE 512gb SSD) to my desktop using the open m.2 slot.

The issue is that the drive shows in the BIOS under Device Configuration -> Hard Disk (M.2 512gb PCIE SSD) and also in Device Manager (Disk Drives -> PCIe SSD) but it does not show in Windows in Disk Management, where I would expect to be able to initialize, set to GPT, set drive letter and format (NTFS). Not sure why this would not be plug-play.

I've been searching for a solution for the past two days and tried several things but none have worked, so I am finally posting.
Things I've tried that have not worked:
  1. Ran Memory Diagnostic Tools - I read this has helped some people with this issue. Did not find any issues and did not find drive.
  2. Pulled and re-installed in the socket. (Only one available m.2 socket so can't try in another and I don't have another computer with m.2 support)
  3. Ran Windows Update (up-to-date)
  4. Ran driver updates in Device Manager and shows using best driver (no yellow errors icons)
  5. In Device Manager I removed the IDE ATA/ATAPI Controller, restarted and let it reinstall. (did not fix).
  6. In Device Manager I've got the following drivers:
    Standard SATA AHCI Controller (Updated -> Using Best Driver)
    Microsoft Storage Spaces Controller (Updated -> Using Best Driver)
    Standard NVME Express Controller (Updated -> Using Best Driver)
    I've checked Windows Update about 5 times today and everything is Up-to-date.
  7. I could get the drive to show in Disk Management if I went to System -> Storage -> More Storage Spaces -> Manage Storage Spaces -> Here I could see the drive and make it a storage space (which I don't really want to do) and set a drive letter. Then if I went into Disk Management it would show where I could format it to NTFS, but not initialize or set to GPT. When I remove the storage space, it was removed from Disk Management also. So not the fix.
  8. Ran HP Diagnostics. Storage section only shows C: drive to scan. No SSD, but because I can't give it a drive letter, I'm sure that's why.
My main plan was to load my OS to this and use as my primary drive, then use my current primary drive (1TB HDD) as backup/storage or setup for dual boot. But before that, I just need to get this thing to show in Disk Manager so I can get it initialized and formatted.

System: HP Pavilion 590-p0066
Motherboard: Lincs 843B
Factory Hard Drive (OS) : 1 TB 7200 HDD (spinner)
OS: Windows 10 Home (64 bit)
BIOS Settings: SATA Emulation = AHCI

Everything I could find suggests the MB supports NVME PCIE.

Here is the exact m.2 SSD:
https://www.microcenter.com/product/600420/512GB_SSD_3D_NAND_M2_2280_PCIe_NVMe_30_x4_Internal_Solid_...

I did find this that says NVME PCIE is supported on the 590 motherboards, even though it was by a contributor, not the HP Agent.
https://h30434.www3.hp.com/t5/Desktop-Hardware-and-Upgrade-Questions/Upgrading-Optain-drive-to-m-2-s...



Any suggestions?
Thanks,
 
Last edited:
Dec 30, 2019
4
0
10
0
Deleted the pools.
I also deleted the SSD from Device Manager to see if it would trigger anything.

Now, not sure if this had anything to do with it, but after I deleted the pools, nothing changed in Disk Management. I decided to do a shut-down and try to pull the SSD again as a last ditch effort. That little screw is a PITA for big hands. Anyway.. on reboot, nothing. Then I got an alert from HP that there were updates. One of which was BIOS. Hummm.. Did the update (and 8 others it said were needed) and now I see the drive in Disk Management and was able to format. YES!!

I've been so good to document all steps to help others with this same issue in the future, but at the end I was just "doing things" and crossing fingers.

All I can say, is it may have been the pools. It may have been the pull, it may have been the BIOS update (thank HP for taking 3 days to notify me via PC Assistant).

End result, working.
Thanks everyone!
 

ASK THE COMMUNITY

TRENDING THREADS