Question M.2 SSD Not working or showing after Windows update?

HuniPotter

Reputable
Mar 20, 2016
8
0
4,510
0
Hi, so I've just set my pc to install the Windows may 2019 update after I kept on being nagged to install by the OS. Naturally I've gotten up and left my PC for a good 10min only to come back to my computer only booting to bios and my ssd vanishing from the boot order menu? I've made absolutely 0 changes to my computer for this to happen aside from installing an update that Windows was forcing me to do. I have no idea what's happened here and any help would be greatly appreciated

PC is:
I7 6700k
16gb of hyperx fury ram
Asus z170-ar
Gtx 1070
And the sdd is a 250gb Samsung 960 evo

I've also tried reseating the ssd with no luck
 
Sep 2, 2019
61
2
45
1
i have the same problem, but only in de bios, fiest it seen my drives as uefi boot drive, but now as windows boot manager drive. how can i get the uefi back infront of it in de bios ?

i got x570 ultra from gigabyte. with latest bios F5 version.

i tried turn off/on the CSM
i tried in bios the only find and reboot the uefi,
i have put nvme Raid option on and off to see if something pops up then, nothing happens.

i only can see the nvme aorus 512 as a windows boot manager drive, were i can boot from.
was like Hunipotter sayd, din't do anything or din't change a thing in the bios, the Uefi Boot is just totally gone.

i wiped the nvme drive, del all partitions, did new install win10 from usb drivve that is saying UEFI drive if i put it in and watch the bios it says uefi usb drive... and i installed win10 with the new windows media creation tool/ installer.

and then i don't see uefi infront of my nvme drive anymore :( Grrrrrrr WY is the Uefi boot option gone.
drive is in GPT format.


plz help, greets, Jørn Mulder
 
Sep 12, 2019
2
0
10
0
I have this exact same issue, windows update (the most recent) has seemingly stopped my m.2 drive from booting. Disappeared as an option from bios as well

If I run the windows recovery tool from a usb stick it recognises the drive in there. And shows it still has the partitions and data etc

the CSM option appears to have the biggest change. Enabling it allows my old sata ssd to show in the boot option alongside my dvd drive. With CSM off. Nothing appears there
 
Guide to installing Windows 10 on M.2 NVMe drive is found in this thread:
 
Sep 2, 2019
61
2
45
1
Guide to installing Windows 10 on M.2 NVMe drive is found in this thread:
did that all, i havve bios version f5 for my ultra x570 gigabyte, i clean installed it, now it all works again.

just never install the amd achi controlers . and system still is not good, if you press f12 to boot. there is a empty thing in my list, that i my nvme drive, strange !!!
 
Sep 13, 2019
1
0
10
0
I'm also having the same issue. Samsung 960 Evo 1TB M.2, it's not my boot drive or anything. Worked fine until windows forced the last update on me, then gone - not in disk management or bios. I reinstalled the drivers from Samsung, and applied a few more windows updates.. but it's still gone. MoBO is Gigabyte X99-Phoenix SLI, bios date is old - 5/2016 - but nothing changed except the windows update. I do have another SSD that I boot from, sata not M.2, and everything is fine with that.

Jornmulder - are you saying you got yours fixed?
 
Last edited:
Sep 2, 2019
61
2
45
1
YEA IS FINE WITHOUT the uefi string.. i just don't have it, i only got it the first time that i started my just build pc, it was showing first uefi infront of the windows startup boot, i had problems and wiped and clean install, after that i never seen the uefi string again, and Bios F5 was not showing my drive at all, now i updated it, to F6a and now i can see the drive again, still no uefi but it sayd windows boot manager.. and pc runs fine.. but no uefi string for me. i don't care about that, if pc runs fine, it just says in bios that it is windowsboot drive.

-Win10, 64x
-Auros 512 nvvme M.2 (non gen4)
-Ryzen 3700x
- Gigabyte, x570 Ultra
-Evga 1050 ti SC
-3200 mhz g.skill
-600 watt be-quiet (80 plus gold)
 
Last edited:
Sep 2, 2019
61
2
45
1
i will tell you if i get awnser back from gigabyte...
if it is a problem for people who can't see the uefi string infront or not or just windows boor manager drive.
 
Last edited:
Sep 2, 2019
61
2
45
1
just d/l the latest F6a bios, update it, and you will see your drive again in F12 boot menu.

but the uefi with or without, i still don't understand.
 

ASK THE COMMUNITY

TRENDING THREADS