M.2 SSD Problems - Clean Install Windows 10

Jan 15, 2019
3
0
10
0
Hello everyone!

I have a Asus Zenbook Pro - UX501JW - and about 4 or 5 weeks ago the SSD broke. The harddisk health (according to Harddisk Sentinel) had been bad for some time now, and now it decided to die. I have tried several M.2 SSD' to replace it with, but I have encountered alot of problems with compatibility during my attempts. I have tried to fix this for 2 weeks, and I'm still back at start after every attempt. I hope someone here could help me shed some light on these problems.

Before it gets suggested, I have done the following:
- Updated BIOS to newest version from Asus website
- Consulted Asus technical support through chat - they didn't know anything more than I did...
- Warranty is out, so sending it to workshop is out of the picture.

At first I purchased a Kingston SA1000M8/480G (480GB) M.2 NVMe SSD.

My initial thought was just to try installing Windows 10, as I didn't bother to even check if it was visible in BIOS. I was sure that if the Windows Installer can see it, then the BIOS should see it for sure. When I initially tried to install it the first time, I got the following message:

Windows cannot be installed on this disk. The selected disk has an MBR partition table. On EFI systems, Windows can only installed on GPT disks.
So after some research, I discovered that I can use Diskpart.exe while in the installer by using 'Shift + F10' to open CMD.
1. Using 'Clean' in Diskpart, followed by 'Create Partition Primary size=120000', and using 'Activate' did not work.
2. Leaving the disk un-partitioned, and letting the Windows installer partition itself did not work either.
3. Using Clean, followed by 'Create Partition Primary size=120000' and 'Convert GPT' allowed the installer to start. However, it only partition the drive, and completes the first stage of the install. When it's trying to restart to complete the install, it just sends me back to the start of the install again; where I have to choose Keyboard Layout and Language.

So yeah, no matter what I did, I would either be halted from installing Windows 10 on a MBR-disk, or I would be stuck in a install-loop. After speaking to tech-support from the company I purchased the SSD from, we thought that maybe my Asus Zenbook Pro didn't support NVMe SSD'. As far as I could understand, I get stuck in the install-loop because BIOS can't detect the drive to continue the install after the restart - so it just sends me to the USB drive to install again. So I returned the drive, and purchased another one.

This time I purchased a Samsung 970 PRO V-NAND NVMe 512GB (MZ-V7P512BW)

The guy at tech support told me this one should work, as it wasn't NVMe. Turns out he only thought it wasn't NVMe as it didn't say so in the product title on their website. Anyways, I thought I should give it a try.

I had the exact same problems as the Kingston SSD. Either it refuses me to install Windows 10 on a activated MBR drive, or it just sends me into the install-loop. I decided not to return this one yet, and purchase another drive to try before I did anything else.

This time I purchased a Kingston UV500 480GB M.2 SATA SSD

This disk is not a NVMe. The computer was purchased in 2015, and I thought perhaps that SATA was most probably the SSD it had to use.

This time it's not even detected in Diskpart. Neither Diskpart, Windows Installer, or BIOS can see the drive. Now I have no clue what to do. 'ChkDsk' obviously doesn't work as Diskpart can't see the disk.

My horrible limited

***** [Moderator edit to remove profanity. Remember that this is a family friendly forum.]

Aptio Setup Utility BIOS


As this is a notebook (can't figure out any other reason), Asus has provided the computer with litteraly the worst piece of crap BIOS I have ever encountered. There is very limited options to do anything, and the few options I have doesn't seem to make any difference when changed. It's actually so few options that I can list them all for you here:

Main:
- System Date
- System Time

Advanced:
- Start Easy Flash
- Internal Poiting Device [ENABLED]
- Wake On Lid Open [ENABLED]
- Power Off Energy Saving [ENABLED]

- Intel Virtualization Technology [ENABLED]
- Intel AES-NI [ENABLED]
- VT-d [ENABLED]

- Trusted Computing
Security Device Support [DISABLE]

- SATA Configuration
SATA Mode Selection [AHCI] (AHCI / IDE)

- Graphics Configuration
DVMT Pre-Allocated [64M] (64M / 128M / 256M / 512M)

- USB Configuration
Legacy USB Support [ENABLED] (Enabled / Disabled / Auto)
XHCI Pre-Boot Mode [ENABLED] (Smart Auto / Enabled / Disabled)

- Intel(R) Thunderbolt
Security Level [Unique ID] (Unique ID / One time saved Key / DP++ only)

- Network stack
Network stack [DISABLED] (Disabled / Enabled)

BOOT:
Launch CSM [ENABLED] (Enabled / Disabled)

(These options is only available if the Windows 10 USB is plugged in)

Boot Option #1 [KingstonDR HyperX 3.0]

Hard Drive BBS Priorities [KingstonDR HyperX 3.0]

- Add New Boot Option
Add boot option [WRITE NAME OF BOOT OPTION]
Path for boot option [PCI(1D|0)/USB(1,0)/USB(2.0)/HD(Part1,Sig5a571ca5-6dd8-43b8-be49-2e3024b8614b)]
Boot option File Path [GREYED OUT]
Create [To create boot option with this NAME and PATH]

- Delete Boot Option

Security:
- I/O Interface Security
Wireless Network Interface [UnLock] (Lock / UnLock)
HD AUDIO Interface [UnLock] (Lock / UnLock)
Card Reader [UnLock] (Lock / UnLock)
-- USB Interface Securtiy
USB Interface [UnLock] (Lock / UnLock)
External Ports [UnLock] (Lock / UnLock)
Bluetooth [UnLock] (Lock / UnLock)
CMOS Camera [UnLock] (Lock / UnLock)

Save & Exit:
Save changes etc, with Boot Override at the bottom allowing me to select the Windows 10 Install USB. The option dissapears when restarted without the USB inserted.
I have probably read through over 100 different forums of people with similar problems. I still have the Samsung V-NAND NVMe disk here so I can try it again. At least that was detected by the Windows Installer.

As far as I've understood when it comes to M.2 SSD' - there is two types: PCIe and SATA. As the SATA won't show up anywhere, I guess my Asus Notebook only supports PCIe. This means that the old drive was a PCIe - but how did Asus make that work with a BIOS only supporting IDE / AHCI? This is so confusing. I just tried to insert the Samsung 970 PRO M.2 again, and run the installer: exact same thing happened. After using Diskpart to convert it to GPT, it runs the install to restart, then goes back to start.

Any help is much appreciated!
 

karenjoly

Respectable
Apr 13, 2018
1,329
19
1,815
166
I am interested to confirm that any of the NVMe drives are identified in the bios ?


You should ensure you have properly installed windows.I say that because the issue appears to be with the install (USB ) device. Try this installation procedure to cover this off.

Create an up to date USB install media by following the steps outlined here:

https://www.microsoft.com/en-ca/software-download/windows10

Then disconnect or disable all hdd /ssd drives but the one where you will install windows.

Insert the USB media tool, with the windows install files, into the board.

Next, startup and go to the board setup (BIOS) and ensure the board is configured to use UEFI boot settings, CSM is enabled and SATA mode set to AHCI.

On the motherboard boot device menu, select the command that identifies both the firmware mode and the device. For example, select UEFI: USB Drive, Windows Boot Manager will also work, and list that device in the first boot slot on the board.
Reboot. Install begins.

When choosing an installation type, select Custom. On new disks, the drive will show a single area of unallocated space. If there are partitions, select each one and then "delete".

Select the unallocated space and click Next. Windows detects that the PC was booted into UEFI mode, partitions the drive using the GPT and begins the installation.Remove the USB device after the install/reboot

Any data on the drive will be lost
Good Luck.
 

nobspls

Notable
Mar 14, 2018
892
9
1,165
86
The BIOS does not just support AHCI or IDE, although those are the only possible options for the SATA port. nVme drives do not ever show up on the SATA connectors.

You may need to slipstream in drivers for your hardware to boot and successfully install windows.

An alternative you can do, is clone a good install (usually this why make backups of the orignal install) to the SSD and you'd be good to go. You make sure to have all the drivers you will need preinstalled in that image/backup image.
 
Jan 15, 2019
3
0
10
0


None of the NVMe drives have been detected by BIOS.

The USB is created with Microsoft Media Creation Tool. The procedures from them is followed, and USB is made bootable with up-to-date Rufus software. I am trying to create the USB Install Tool through the Microsoft Media Creation Tool directly this time.

There is only one drive port on the computer - so there isn't anything else to unplug.

There is no option in my BIOS to select UEFI - however, my #1 Boot Option is [UEFI: KingstonDT HyperX] - so I guess that means it's configured as UEFI. All other BIOS settings are set to your reccomendation.

Now that CSM is enabled, the computer doesn't even want to boot to the Windows 10 Installer.

Edit;

I actually was able to boot into the installer after some restarts. When the installer is complete, and the machine reboots, leaving the USB in will take me back to the start of the install, removing the USB after reboot takes me staright into BIOS. The harddrive still doesn't appear in BIOS.
 
Jan 15, 2019
3
0
10
0


The only drivers I can find that might be relevant for the install is BIOS Utilities (which is an .exe for install through Windows) and Chipset drivers. Neither of them seem integratable into the Windows install. The Install file from the USB is just just .esd - not .wim - like many tutorials use to integrate drivers into install USB.
 

karenjoly

Respectable
Apr 13, 2018
1,329
19
1,815
166
Can you post a picture of the original drive ? Is there another one available from the distributor ?

I suggest that you have done enough to make clear that the board will only boot the ssd what it came with in the machine. Makes me queasy cause the wife has the same Zenbook too.
 
Feb 27, 2019
1
0
10
0
Can you post a picture of the original drive ? Is there another one available from the distributor ?

I suggest that you have done enough to make clear that the board will only boot the ssd what it came with in the machine. Makes me queasy cause the wife has the same Zenbook too.
Hi, did you solve the problems?
I tried now all i find on forums - nothing working to me. My laptop Zenbook UX501JW-cm099h . I don't have installed ssd by default in this model, but i have slot, so i bought Samsung 970 Pro too :c

970 pro undefined in:


BIOS v.211 (cms mode, security, key managment, and many more combinations of options)
Windows
Ubuntu
Acronis usb
Windows usb created by Rufus gpt, mbr, ... i tried all the options)

Asus support told me:
Your laptop supports the NVMe protocol. But the drive Samsung Pro 970 is not tested for compatibility, and its work is not confirmed. Recommended drives that are guaranteed to work :
SANDISK/SD7SN3Q-128GB
MICRON/MTFDDAV128MBF-1AN1ZABYY
SANDISK/SD7SN3Q-256GB
MICRON/MTFDDAV256MBF-1AN1ZABYY
SAMSUNG/MZHPU256HCGL-00005
SAMSUNG/MZHPV256HDGL-00000
SAMSUNG/MZHPV512HDGL-00000 (it's Samsung SM-951)
SAMSUNG/MZHPU512HCGL-00005


Also i check 970 Pro on another notebook - working.
From another notebook i check on my super Pro notebook ssd Samsung PM-951 - not working. Oh, look :rolleyes: - PM-951 and SM-951 ( SAMSUNG/MZHPV512HDGL-00000 )
In our case PM-951 & SM-951 has a small difference (or this article ), but asus just told me go to service center...

I think it's old BIOS from asus(
 
Last edited:

Similar threads


ASK THE COMMUNITY

TRENDING THREADS

Latest posts