Question MB has wrong BIOS

slatchley1

Prominent
Apr 29, 2018
63
3
545
1
I bought an MSI X570A Pro MB. I had to RMA it. Got a replacement but it has been slow as molasses so wanted to put the latest BIOS on it. Flashing BIOS failed and it turns out the current BIOS is for the X570 Gaming Edge Wifi. Any idea how I can get the correct BIOS on it? I have contacted MSI
 

TJ Hooker

Glorious
Ambassador
How exactly did you determine that the current BIOS is for the Gaming Edge?

Are you using the M-Flash utility in the BIOS to do the update? What exactly did it say when you tried?

Please run CPU-Z and post a screenshot of the Mainboard tab.
 
Reactions: PC Tailor

slatchley1

Prominent
Apr 29, 2018
63
3
545
1
How exactly did you determine that the current BIOS is for the Gaming Edge?

Are you using the M-Flash utility in the BIOS to do the update? What exactly did it say when you tried?

Please run CPU-Z and post a screenshot of the Mainboard tab.
When in bios that’s what it says at the top of the screen and when in mflash the current bios is for the gaming edge View: https://imgur.com/a/5ZAVO9E
 

slatchley1

Prominent
Apr 29, 2018
63
3
545
1
Please post a screenshot of CPU-Z like I asked, and also a screenshot of the BIOS where it says X570 Gaming Edge Wifi like you say.

What happens when you try to flash the BIOS?
Will do. Might be tomorrow. When I try to flash I choose the usb drive/choose the file/hit enter. It just takes me back to the choose file screen
 

TJ Hooker

Glorious
Ambassador
In your previous screenshot it looks like the item you have selected may be a directory, not a file. When you downloaded the BIOS from MSI's website, did you unzip it? If not, do that and then copy the BIOS file to the top directory of the USB stick.
 

ASK THE COMMUNITY

TRENDING THREADS