Question Monitor issue or something else?

Feb 13, 2020
1
0
10
0
Hello, long time lurker.

I recently built a PC and been up and running 3 weeks now without any issues until the last couple days.
I have 2 Sceptre C24 144hz curved monitors and one of them has done a strange artifact and freeze. If I unplug the monitor and plug it back in then all is fine which makes me think its the monitor. Also last night when I powered the PC down the same monitor didnt completely shut off, the back light stayed lit then it got lines across it that changed position every few seconds like a screensaver would. The artifacting and freezing has only happened twice so far. Ive been monitoring temps and everything and thats all been stable.
Is this an issue with the monitor or something else?

Mobo: Gigabyte x570 Aorus Pro wifi
GPU: EVGA RTX 2070 Super XC Ultra
CPU: Ryzen 7 3700x
PSU: EVGA 750 G5
RAM: G.Skill TridentZ RGB 32GB (2x16) 3200mhz
Windows 10 Pro
 
Last edited:

Ralston18

Titan
Moderator
Take a look in Reliability History. You may find error codes or warnings that correspond to the times of artifacting and freezing.

Dual monitors: swap the monitor's connections to the GPU.

Determine if the problem stays with the original problem monitor or moves with the GPU port.

Swap the video connection cables.

Try the monitor on another known working computer.

Try another known working monitor in place of the monitor that is artifacting and freezing.

Key is to narrow down the possible sources directly or by elimination.
 

ASK THE COMMUNITY

TRENDING THREADS