Monitor MSI Optix with weird pixel issues.

Evan Gutierrez

Reputable
Jul 5, 2015
13
0
4,510
0
Hello,

So I recently purchase an Open Box MSI Optix MAG27CQ from Amazon. I just receive it and installed it. First thing I notice when I power it ON, it shows the MSI logo and hundreds of pixels blinking red,green and blue colors. Then I connect to PC and still has the same issue. The problem is clearly noticeable with black backgrounds but hard to notice with colors.



I live in Central America, so I cant use the warranty/return since shipping back to US is as costly as the monitor itself. So I will have to stick with it. I decide to purchase the monitor online cause in my country most monitors are low end 1080p 60hz at incredible overpriced tags. When I am playing after a while I forget about the issue and don't notice it but I really want to fix it.

I have an electronic bachelor degree, so I plan to mess a bit with the inside of the monitor, look for cold solder or something. What I need if there is someone expert on monitor that can guide what could be causing this issue, if it can be resolve or what I should check. I am attaching an image of the issue as a link to a video of the problem.

Youtube Video

Thanks for you time!
 

Evan Gutierrez

Reputable
Jul 5, 2015
13
0
4,510
0
Hi,
So if someone else get the same problem, I found a connector not properly connected to a board, as illustraded in the picture, was a bit though disassemble since there is no videos on how to do it, but basic electronic experience will guide you.


Cya
 

ASK THE COMMUNITY

TRENDING THREADS