Question Monitor no signal after upgrade to Sapphire r9 280x from old AMD Radeon HD 7800

Reii

Distinguished
Jan 2, 2013
4
0
18,510
0
So sorry I am new here and very beginner but I'd love to learn and understand my computer more. Please excuse my noobness.

So sorry for the lengthy post, wanted to give as much info and background as possible and what I've tried already to help.

A friend gave me his old GPU (Sapphire r9 280x) after he upgraded his because it was just collecting dust and I was looking for an upgrade from mine (AMD Radeon HD 7800 series).
After I installed it (after watching 4 videos and reading 3 guides)(yes I touched metal before touching the GPU to discharge any potential static), and plugged the monitor into the HDMI into the new GPU, there is no signal on my monitor and it is just black.
I can hear my computer turn on normally and all the fans are going, including on the new GPU.
I have uninstalled the 'AMD' software in the Programs.

I have tried various combinations to see where might be the problem but am quite scared to go further with my little experience.
I tried:
  • New GPU installed and monitor in mobo HDMI or mobo DVI or mobo VGA = Computer turns on, keyboard/mouse doesn't light up, no signal on monitor
  • Old GPU and monitor in mobo HDMI = black screen but keyboard and mouse lights up. Went to plug the HDMI into the old GPU and it works fine and normal
  • NO GPU installed and monitor in mobo HDMI = WIndows and everything starts like normal
I've tried the DVI and VGA in the combos above but still no different than the HDMI.
And I've installed my old GPU and new GPU over again and over again to test things and look up more solutions and the old GPU always works fine.

Here are my computer specs:

Windows 10 64-bit
Power Supply: XFX 650W PRO650W Core Edition Single Rail ATX 12V 53A 24PIN ATX Power Supply 80PLUS Bronze PSU [P1650SNLB9]
Motherboard: MSI Z77A-G43 DDR3 CrossFire Motherboard
Processor: Intel Core i5 3470 CPU
RAM: 24GB total: Corsair Vengeance Blue CMZ8GX3M2A1600C9B 8GB 2X4GB DDR3-1600 CL9-9-9-24 Dual Channel Memory Kit [CMZ8GX3M2A1600C9B]
and Corsair Vengeance 16Gb (2X8Gb)Ddr3 1600 Mhz (Pc3 12800) Desktop Memory (Cmsx16Gx3M2A1600C10)
Old GPU: XFX Radeon HD 7870 Double D 1000MHZ 2GB 4.8GHZ GDDR5 DVI HDMI 2XMINIDP PCI-E Video Card [FX787ACDFC]

New GPU: Sapphire r9 280x

One idea I can possibly think of is that my BIOS is telling my system that if it detects a GPU, to try and use it at all cost?
There is also this little button on the side of the new GPU that I'm unsure about. I looked it up and it said "It's the UEFI BIOS button, The benefits of UEFI on this video card are improved boot times and resume times, and secure boot. This feature can be enabled or disabled with this button on top of the video card. By default, it is in legacy mode, with UEFI disabled. Turning it on is as simple as pushing the button, and the button will light up as blue."

If I am missing any more information, feel free to ask!
Any help is appreciated!

Thank you again for this wonderful forum. I've lurked on here for the past few days trying to find a solution but am stumped.
 

ASK THE COMMUNITY

TRENDING THREADS