[SOLVED] Motherboard and cpu fan turns on, but keyboard mouse and gpu not working

Aug 31, 2020
1
0
10
0
Around 2 months ago I bought a ryzen 5 3600 with 2x8gb of g.skill ripjaws V 3200mhz and a P1 m.2 ssd, along with the asrock b450m pro4 mobo. I already had a 430w PSU, I cloned my OS from a hdd to the m.2. It worked flawlessly apart from an occasional blue screen which I couldn’t figure out but it only happened 2-3 times. Eventually one day my screen suddenly went black and my pc turned off but my mouse light was still on? So I used the power button to restart it, mouse light turned off and nothing worked apart from only the motherboard cpu fan. It seemed like it locked up or something, anyway I couldn’t figure out so I requested a RMA. I ended up procrastinating until eventually it was too late. So a week or so ago I purchased the b450m steel legend. Using all of the same peripherals from the last build that shut off, I hooked all of the stuff up to the new motherboard being extremely careful. Turn it on, rgb lights come on and my cpu fan turns on and that’s it. Same exact <Mod Edit>. When I unplug and plug in my keyboard cable the key lock lights flash as if it’s getting power and when I turn on the pc the gpu fans turn a split second and stop indicating it has power. I just re hooked up an old motherboard using the same GPU from the system at hand, the same PSU, the same hard drive, and everything works fine. So I know the gpu is fine, the PSU is fine. So I thought maybe it’s the ram, so I took out the system at hand ram and replaced it with older similar ram, ddr4 Corsair vengeance 2x8gb (3000) MHz and STILL nothing. When I turn on the pc I hear a single dull low tone beep that I’ve always heard which I’m assuming indicates everything checks out ? So I’m completely stumped any help is greatly appreciated

EDIT: I can’t find where to delete this post so I’ll say that I just now fixed the issue either by :
A: Booting with no gpu in
B: Unplugging PSU from the wall and holding my power button for 30 seconds twice
Did them both at the same time, one of them fixed it !
 
Last edited by a moderator:

ASK THE COMMUNITY

TRENDING THREADS