Question Motherboard detects boot device, but won't boot from it automatically

Aug 30, 2020
7
0
10
0
I just finished a new gaming PC build, but I'm having issues getting Windows to automatically boot from the SSD it's installed on (it was an SSD I've used before, but I wiped it and did a fresh install of Windows 10 for this new build). When I turn my PC on, it stops at the American Megatrends splash screen (after the DEL or F2 BIOS prompt) and says "Detected devices... SATA6G_1: Samsung SSD 860 EVO 500GB" followed by "Press F1 to Run SETUP".

When I press F1 and enter the BIOS screen, it shows my SSD listed under Storage Information (as AHCI), and even shows it in the boot priority menu as the only available device to boot from. When I enter the boot menu and manually select the device, it boots from it just fine. The issue is that it just won't boot from it automatically when I power my PC on.

Here are my specs:
  • Motherboard: ASUS Prime Z390-A ATX LGA1151
  • CPU: Intel i9-9900K 3.60 GHz
  • GPU: NVIDIA GeForce RTX 2080 SUPER
  • PSU: EVGA SuperNOVA G2 750W 80+ Gold
  • SSD: Samsung SSD 860 EVO 500GB
  • RAM: Corsair Vengeance LPX 16 GB (2x8 GB) DDR4-3000 CL15 (x4, so 32 GB total)
  • OS: Windows 10 Pro
Things I've already tried:
  • Unplugging every other drive/device except for my SSD and booting
  • Updating the BIOS
  • Resetting BIOS settings to default
  • Making sure my SSD is plugged into SATA slot 1
  • Testing the SSD on another rig (the SSD seems to be working fine)
I'm hoping I've just missed some obvious BIOS setting, but I'm honestly stumped. Any idea how I can have it boot from my SSD automatically, or what the issue might be? Faulty motherboard?

(For what it might be worth, when I manually boot from my SSD and Windows it seems like it's having trouble keeping my display drivers installed. In the Device Manager under Display Adapters, it shows a warning next to my RTX 2080 "Windows has stopped this device because it has reported problems. (Code 43)" which disappears when I install the latest GeForce driver, but that warning shows back up after I restart my PC. Not sure if this is related or not...)
 
Aug 30, 2020
7
0
10
0
Yep buddy!
Sorry, I should've clarified haha: the drive was already set as the Boot Priority 1 (so presumably it's the default drive) and yet the problem is still happening. I start the PC up but it won't boot automatically, so I have to go into the BIOS and boot from it manually, even with it set as the default boot drive.

Any idea what the issue could be? Googling around, it sounds like it could be a faulty motherboard, but I'm not sure if there's anything else I can check first.
 
Aug 23, 2020
79
6
45
2
Try this. Enter the BIOS and change the boot order so that the HDD isn't listed. Save changes and reboot. Don't worry about the missing OS message, as it is expected. Now restart and enter the BIOS again. This time, reverse the change you made earlier and reinstate the HDD as a boot device. Save changes and reboot. What you have done is to toggle the boot setting. This sometimes helps if a setting isn't behaving as it should. Test to see if it now boots up without the need to enter the BIOS each time.
 
Aug 30, 2020
7
0
10
0
Still no luck... I removed the SSD from the boot priority list (so the list was empty), saved, then rebooted, set the SSD back to Boot Option #1, rebooted again, and it still goes to the BIOS screen instead of booting from the drive automatically.

This is driving me crazy. :( Is it a faulty motherboard?
 

Mtop

Upstanding
Nov 21, 2019
412
40
290
30
Need bios settings. Are you in UEFI mode or legacy/CSM
Does the disk have a bootmgr file or a efi file.
File determines which boot method.
Also how was disk formatted? GPT orMBR?
 
Aug 30, 2020
7
0
10
0
Need bios settings. Are you in UEFI mode or legacy/CSM
Does the disk have a bootmgr file or a efi file.
File determines which boot method.
Also how was disk formatted? GPT orMBR?
In the BIOS, CSM is set to "disabled" but I noticed the drive doesn't explicitly say "UEFI" next to it in the boot menu—instead, the device is listed as "Windows Boot Manager (SATA6G_1: Samsung SSD 860 EVO 500GB) (500.1GB)". I noticed that if I plug in another device, like the USB drive I installed Windows from, it says "UEFI" before the rest of the device name.

I believe it does have a bootmgr file, but where on my drive can I check that? FWIW, in the USB drive I installed from, there's a bootmgr file and bootmgr.efi file in the root folder.

The disk is formatted as GPT.
 
Aug 23, 2020
79
6
45
2
Still no luck... I removed the SSD from the boot priority list (so the list was empty), saved, then rebooted, set the SSD back to Boot Option #1, rebooted again, and it still goes to the BIOS screen instead of booting from the drive automatically.

This is driving me crazy. :( Is it a faulty motherboard?
These can be faulty -
  1. Motherboard
  2. Motherboard BIOS
 
Aug 23, 2020
79
6
45
2
Or,
I Think your HDD and SSD both have OS installed. Just try to boot your PC without HDD. Detach the HDD and then boot and vice-versa
 
Aug 30, 2020
7
0
10
0
Or,
I Think your HDD and SSD both have OS installed. Just try to boot your PC without HDD. Detach the HDD and then boot and vice-versa
There is no HDD though. The only drive plugged in is the SSD, and that's the only drive I've installed the OS on. :confused_old:

I could probably try digging up an old HDD somewhere and wiping/installing on that, but I've tested this SSD on another machine and it seems to be working perfectly fine, so I don't think the issue is with the drive's hardware.
 

Mtop

Upstanding
Nov 21, 2019
412
40
290
30
Try turning on CSM / legacy boot. For UEFI disk has to formatted in GPT by windows and run in uefi mode. If you installed a disk several years old it may not have been uefi capable and was then formatted MBR.
 

ASK THE COMMUNITY