shas595

Distinguished
Sep 3, 2013
24
0
18,510
0
(Posted in Memory Forum but maybe someone can help here?)

I have an Asus Z68 Pro3 Motherboard, latest BIOS. I have installed 4 matching sticks of RAM, 4x 4GB - no matter what I do the BIOS will only see 8GB.
If I put sticks in A1 & B1 it shows 8. If I add another stick to A2, it then shows A1 & A2, 8GB total, B1 shows empty. If I add all it shows A2 & B2.
I put 16GB from another PC in, same issues. I took the RAM from that PC and put in another, shows 16GB. So the issue is on the motherboard (I think)
BIOS Shows 8GB Max, Windows 10 Home shows 8GB... BUT ......... CPU-Z shows 16GB INSTALLED?? Really pulling out my hair on this one. Any ideas?
 
(Posted in Memory Forum but maybe someone can help here?)

I have an Asus Z68 Pro3 Motherboard, latest BIOS. I have installed 4 matching sticks of RAM, 4x 4GB - no matter what I do the BIOS will only see 8GB.
If I put sticks in A1 & B1 it shows 8. If I add another stick to A2, it then shows A1 & A2, 8GB total, B1 shows empty. If I add all it shows A2 & B2.
I put 16GB from another PC in, same issues. I took the RAM from that PC and put in another, shows 16GB. So the issue is on the motherboard (I think)
BIOS Shows 8GB Max, Windows 10 Home shows 8GB... BUT ......... CPU-Z shows 16GB INSTALLED?? Really pulling out my hair on this one. Any ideas?
It may be an incompatibility so you best list full system specs....exact motherboard and BIOS rev, CPU and memory brand/model.

You might also start with a CMOS reset as that often helps.
 

ASK THE COMMUNITY