Question Mouse, keyboard and headset doesn't work

Jarm__

Honorable
Jan 7, 2017
29
0
10,530
0
As the title says, I have issues with getting any USB devices to work. Upon booting the computer at the BIOS section it states:

USB Devices total: 0 Drive, 0 Keyboard, 0 Mouse, 0 Hub

Detected ATA/ATAPI Devices...

NO Keyboard Detected!

And for the God of me I cannot find out the issue with it. I have tried taking out the CMOS battery to reset BIOS, I have tried different mouses and keyboards (the other mouse only lighted up but still didn't work), my headset doesn't give any sound even though it's plugged into the 3.5mm jack behind the PC. I can't get into the BIOS either because none of the keyboards or mouses work. I have tried re-seating every cable in-case one got loose.

PC specs:

Z370 AORUS Ultra Gaming

I7-7700k

32GB (2x16gb) ram

M2 Samsung 980PRO SSD

I would be very grateful if someone can help me figure out and solve this issue.
 

Colif

Win 11 Master
Moderator
Jun 12, 2015
60,225
5,038
166,290
10,413
Try using PS2 keyboard and update BIOS?

looks like a problem with the bios - https://forums.tomshardware.com/threads/gigabyte-z370-aorus-gaming-7-usb-problems.3399006/


this could help if you use a PS2 keyboard - https://superuser.com/questions/1327184/bios-doesnt-detect-usb-mouse-keyboard-on-first-boot-only-detects-them-after-r

the board has dual bios, it could be the installed one has corrupted somehow
Its mentioned on features page but I don't know if board has a switch on it you can flip. Normal way to access it is if USB works
https://www.gigabyte.com/fileupload/kr/microsite/55/tech_081226_dualbios.htm
 

ASK THE COMMUNITY

TRENDING THREADS