Mouse keyboard do not work at login screen

XDarthvaderx

Prominent
May 10, 2017
5
0
510
0
Hello everyone.
My received a tower today and once I booted it up the mouse and keyboard do not work.

Keyboard works in BIOS.

Tried system restore. Nothing.
Tried unplugging and plugging in after startup. Nothing.
Legacy is enabled.

I am a basic computer person so I really don't know what to do here.

This is an ACER tower
Veriton M498G

It boots up to windows 7 professional.

Any ideas? I really don't want to take it somewhere to get fixed if I can just do it myself. :(
 

aford10

Champion
Moderator
Are you using the USB ports in the front or the back? Do you have an internet connection when you hook it up? If so, once you plug the mouse and keyboard in, it should automatically pick up the hardware and install the drivers.
 

XDarthvaderx

Prominent
May 10, 2017
5
0
510
0
I plugged it in on all USB ports.
I have internet but because this is a new tower I haven't even set it up, so it's running without internet connection.
 

aford10

Champion
Moderator
While in safe mode with network, open the device manager. Expand the USB devices, and you will see a few USB root hubs listed. You can right click on them and go to the properties-->power, and see if and what devices are attached to them. Your mouse and keyboard will be attached to one of them. Uninstall each USB root hub, saving the one your mouse is attached to for last. Once uninstalled, reboot the computer. They will reinstall on restart and rescan for hardware that is attached.
 

XDarthvaderx

Prominent
May 10, 2017
5
0
510
0
I can't open device manager. Mouse and keyboard do not work. I cannot login. I can only start the computer in safe mode with networking but I am stuck on the login screen.
 

Similar threads


ASK THE COMMUNITY