Question Mouse only works in BIOS but cursor disappears and mouse stops responding in Windows

Mar 10, 2019
2
0
10
0
I just replaced my fans in my PC since the bearings were rusted, I hooked it back up today and my Razer Deathadder mouse, which I haven’t had any issues with for over a year stopped working. There is just no cursor on the screen, I tried multiple mouses and even one that was brand new, all the same result. I managed to get into device manager and saw all the mouses weren’t listed as mouses but as “Other Devices”. The cursor appears when I’m in BIOS and after I try resetting but actually getting into windows the mouse completely stops functioning. I downloaded the mouse drivers, tried uninstalling and reinstalling windows but didn’t wipe everything, tried all different ports, nothing. I’m completely stumped and could really use help here.
 

cherry blossoms

Reputable
Apr 13, 2016
767
35
5,390
161
One possibility:
Check your BIOS to make sure nothing accidentally changed. Check XHCI handoff.

If handoff ENABLED, the system attempts to hand over control from the BIOS to the OS for port control. If disabled, the BIOS retains control.

XHCI MODE enabled runs the ports as USB 3. Disabled XHCI mode runs the ports as USB 2.

This is relevant depending on your OS, as Windows 7 does not contain native driver support for USB 3.

Your keyboard works and is plugged into USB?

Posting your motherboard and OS information might help others to assist you better if the above does not resolve the issue.
 
Mar 10, 2019
2
0
10
0
So, I got it to work with the weirdest way possible. I have restarted and hard restarted it numerous times. But I just unplugged everything from the PC and left it off for 2 hours and it’s working again. I have no idea why this was the fix... but it was. Thank you for trying to help though!
 

ASK THE COMMUNITY

TRENDING THREADS