Question Mouse Trouble (razer naga)

Apr 22, 2019
1
1
15
0
Hello all,
I've had a Naga Chroma for about 2 and a half maybe 3 years always worked great. But for the last little while the cursor has been freezing and sometime like jutting and more stiff movement. I've been trying to fix this for the last 2-3 day when the cursor started freezing altogether. I say just the cursor because while it is frozen and unable to move I can still use the buttons on the mouse, I also tried the mouse and my laptop and it doesn't seem to have the same problems. So I don't think the mouse is broken entirely, I though it might be something with the sensor but if I unplug the USB and plug it back in it work fine for a few minutes before freezing again.
I'm thinking it is a driver issue or conflict with the razer software because I can plug in a generic logitech mouse and it works fine. And I don't think it's a problem with the mouse it self because the buttons still work and the sesor does work before it freezes.

Things I've tried.
Cleaned Lens
mouse pad Calibration
Uninstall/Reinstall drivers (mouse/graphics/USB)
Unchecked power settings on USB root hubs to not allow computer to turn off
Uninstall/Reinstall Razer Synapse
Ran virus/malware check
Used CCleaner
reinstall windows

and after doing all these steps multiple times nothings really changed. I can still get the mouse to work for like 2-3 mins after I unplug/plugin it, then freezes again. sometimes if I leave it I notice it starts working again but soon after I loose control again.

I'm trying to think of when I started to notice this but can't pinpoint any changes I noticed.

I appreciate any input, Thank You in advanced
 
Reactions: Reflected
Apr 22, 2019
1
0
10
0
Hey, I have the same exact mouse and it has been doing that to me too. For me, it will randomly freeze up and I can't scroll horizontally but it will move vertically. It only happens for a few seconds but is extremely tilting when playing a game. I usually have it plugged into a USB port on the top of my pc with 2 other accessories. I just moved it and plugged it into the back of my pc so maybe it'll fix the problem because I had so much stuff plugged into the same area. If that doesn't work then aye were fucked buddy. I'll keep you updated.
 

ASK THE COMMUNITY