Mouse will not work on my PC after water spill, but will work on others without issue

chaosclown17

Honorable
Jan 22, 2013
45
0
10,530
0
I recently purchased a Corsair Scimitar Pro after my Razer Ouroborus finally gave up the ghost. The past three or so weeks I've used it it has been fine. However, my cat decided it would be hilarious to knock over my water cup this morning. Fortunately, the damage was minimal and everything appears to be working without issue aside from my mouse. The lights won't come on, the cursor won't move, just completely and totally unresponsive. At first I thought it was water damage. However, after plopping it in a bag of rice for about an hour I tried it on my nephew's computer. Mouse works great. Lights come on, cursor moves, dpi switch works. Basically as good as new.

However, as soon as I plug into my PC it goes back to not working. I've tried it in different USB ports. Both 2.0 and 3.0. I've tried other things in those same USB ports including other mice and they work without issue. I've tried installing the iCUE software. Nothing doing.

For a short period of time some of the lights came on, but other than that the mouse was unresponsive.

Does anybody have any idea what the issue is and how I can fix it?
 

ASK THE COMMUNITY

TRENDING THREADS