Question MS-TECH CS-70 ITX

Feb 24, 2020
4
0
10
0
Hey guys and girls. I was wondering if anyone could offer some advice or ideas. I recently acquired a MS-tech CS-70 ITX. It was going to be deposited in a skip so I claimed it. There appears to be a power issue somewhere and I’ve tested components to see if I can identify the problem.
When I press the power button it just flashes red. I removed the cover and cleaned the heat sink fan which hasn’t made any difference. When I press the power button the fan tries to spin. Not sure if it’s a major problem and not worth the parts or if it could be a power supply issue.

Any advice or ideas is greatly
 
Feb 24, 2020
4
0
10
0
It's worth trying to power it up again but this time, without the battery. If it's so flat, it may not even be capable of passsing mains power through itself.
Thanks for the tip. Just tried that. Unfortunately no luck. Thinking I may have to put into a repair shop to identify the problem.
 

Saga Lout

Olde English
Moderator
Assuming you tried the battery power without the power block plugged in, that eliminates the battery but not the power block.

It would be cheaper to go into the repair shop and ask "do you have a power block just like this one?" (being yours that you took with you) and if they have one and it works, you only pay for the block and not any technical advice.
 
Reactions: JonnyHill
Feb 24, 2020
4
0
10
0
Assuming you tried the battery power without the power block plugged in, that eliminates the battery but not the power block.

It would be cheaper to go into the repair shop and ask "do you have a power block just like this one?" (being yours that you took with you) and if they have one and it works, you only pay for the block and not any technical advice.
Thanks Saga Lout
 

ASK THE COMMUNITY

TRENDING THREADS