Question Msi afterburner not showing any values Ryzen 7 x570 aorus elite + RX 590 8GB

Yung Richie

Commendable
May 13, 2017
4
0
1,510
0
I just bought an Ryzen 7 3700x paired with the Gigabyte Aorus elite x570 motherboard.
i installed windows, installed mobo drivers, installed internet drivers from manufacturer.
then i proceeded to install steam origin uplay AFTER i installed latest version of the motherboard bios (F4J).
I installed Amd Crimson drivers 19.1.1 & later on i tried installing MSI afterburner but it is not showing any values nor is it changeable.. i just want to overclock my rx 590 with ease, i do not like wattman.
Msi afteburner won't even read what driver version i have...
this has happened to me in the past but i fixed it but i can't recall how, it was on intel platform so yeah...

link to image View: https://imgur.com/a/sQjGPG5
 
This is truly odd that nothing shows up.
Afterburner is overrated.
Why not use WattMan since it's already installed within the driver software? It does all the same things AND MORE. If you're overclocking, WattMan allows you to expose AND CHANGE the 7 frequency states and corresponding voltages that the card uses which is much better than the simple frequency and power limit offset that afterburner uses (WattMan can do that also). Sometimes change is a good thing.
 

ASK THE COMMUNITY

TRENDING THREADS