Question MSI B550 Tomahawk cpu light & no display

Dec 23, 2020
1
0
10
0
Hi, i've recently brought some new parts for my PC heres the full setup,

CPU Ryzen 5 5600X
MOBO MSI MAG B550 TOMAHAWK
RAM Corsair Vengeance LPX 16GB (2x 8GB) 3600MHz DDR4
SSD Sabrent 1TB Rocket NVMe PCIe M.2
PSU Corsair CX500M
GPU GTX 980 Ti

I can't seem to get it to POST or display anything whatsoever. Currently what happens when I boot is that the CPU debug light comes on, flashes to DRAM for a split second, then stays on CPU. With no output from my GPU whatsoever.
I've been looking into this for the past couple of days so i've tried these steps, quite a few times:

  • Flashing the latest bios updates onto the motherboard from the MSI website with a flash drive (https://www.msi.com/Motherboard/support/MAG-B550-TOMAHAWK)
  • Clear CMOS by removing the battery for 5 minutes, then putting it back in
  • Trying one stick of ram in every slot
  • Checking for CPU pins (and the CPU is aligned with the motherboard)
  • Reseating everything


If i re-flash the original BIOS version it turns on and eventually all the debug LEDs go out, but with no display in the end again ;-;

Not sure if i'm just missing something completely, if there is something incompatible or if one of the new parts is a dud.
I'd really appreciate any help or suggestions <3
 
Dec 30, 2020
1
0
10
0
I'm facing same problem but I have a ryzen 5 3600 was working fine for 4 months suddenly I started to see a cpu red light not boot screen I clear CMOS JBAT1 and nothing I don't have another cpu to test. Don't know if I can update bios if is not booting. I remove cpu fan and check proccesor seems ok unplugged all cables and verify and nothing.
 

ASK THE COMMUNITY

TRENDING THREADS