Question MSI Tomahawk Z690 won't enter BIOS setup mode

Dec 18, 2021
53
2
35
0
I'm unable to enter BIOS setup mode on my MSI Z690 Tomahawk no matter how many times I press the DELETE key during boot.

It seems like Windows 11 boots so fast that there's no time for the motherboard to detect the keypresses.

I even tried holding the DELETE key down during the entire reboot process.

What should I try?

Thanks.
 
I'm unable to enter BIOS setup mode on my MSI Z690 Tomahawk no matter how many times I press the DELETE key during boot.

It seems like Windows 11 boots so fast that there's no time for the motherboard to detect the keypresses.

I even tried holding the DELETE key down during the entire reboot process.

What should I try?

Thanks.
Yes sometimes it hands over to the OS too quickly.
Try using your F2 function key or try spamming the F11 at start up and see how you go.
 
Dec 18, 2021
53
2
35
0
Man, as soon as I triggered the system restart, I repeatedly hit DEL and F2 as fast as humanly possible and I still can't get in.

Any ideas?
 

Karadjgne

Titan
Ambassador
In windows power plan, make sure that USB is always active, no selected power downs. If you ever get into bios, make sure usb is fully active.

Sometimes changing where the keyboard plugs in matters, certain ports are always fully enabled at all times, where even bios may only startup with some ports not active until after post/os start up.
 
Dec 18, 2021
53
2
35
0
In windows power plan, make sure that USB is always active, no selected power downs. If you ever get into bios, make sure usb is fully active.

Sometimes changing where the keyboard plugs in matters, certain ports are always fully enabled at all times, where even bios may only startup with some ports not active until after post/os start up.
"USB Selective Suspend Setting" was enabled in power options. I just disabled it. Is that what you are referring to?

Another thing that was happening is that I was unable to wake the PC from sleep with the keyboard or mouse. Would that be related to this setting?

Thanks.
 
Dec 18, 2021
53
2
35
0
Figured it out.

Hold down SHIFT while clicking (Windows) Reset .

This will set a flag for Post options on the next boot.

Drill through the menus to "Boot to UEFI".

Turn off Fast Boot.

Also, updated the BIOS to 1.2, which I think addresses this.
 

ASK THE COMMUNITY