My Computer Keeps On Going Into Sleep Mode

Status
Not open for further replies.

PwncakesNRofls

Honorable
Jun 3, 2012
72
0
10,640
1
My problem is fairly simple, just my computer going into sleep mode around every three minutes or so if I don't use my mouse or keyboard. This usually isn't that big of a problem, but when I'm reading a long body of text and not using my mouse or keyboard, it can irk me a little when the screen goes black. I've tried nearly every option on my Windows 7 control panel, but to no avail. Even with my power plan settings directing my computer to never go to sleep and to never turn off its display, it still does the same thing. Strangely enough, this problem only arose after I got a new Logitech M510 wireless mouse. So, people of Tom's Hardware, what do I do to fix this?
 

PwncakesNRofls

Honorable
Jun 3, 2012
72
0
10,640
1

Oh, thanks for that, man. That's just what I needed to do. Problem solved.

 

Joaquin357

Honorable
Oct 26, 2013
1
0
10,510
0
Check to see if your screen saver is set to "Blank." If so, change it to "None." That is exactly what worked for me too. I tried many other changes in Power Options first to no avail. My screen saver was set to BLANK and I changed it to NONE. Before the change my display would go black every 20 seconds or so until I activated the screen with the mouse. Thank you very much. Joaquin
 

ryan_indigo

Honorable
Dec 1, 2013
2
0
10,510
0


This solution perfectly worked for me.Thanks a lot Joaquin. :)
-Ryan
 

ryan_indigo

Honorable
Dec 1, 2013
2
0
10,510
0


This solution perfectly worked for me. Screensaver changed from 'Blank' to 'None'...Bingo!
Thanks a lot Max. :)
 

hemantrhtk

Reputable
Feb 21, 2014
1
0
4,510
0
Tonight I was watching movie on my TV being broadcasted via HDMI from my Laptop.

It was annoying to force my laptop from dying every now and then. (Somehow I was not able to change power management settings to never sleep, don’t know why!!!)
So here is the powershell script solution :
only move mouse ( http://sharepoint.asia/can-i-stop-my-screen-from-locking-due-to-inactivity/#onlymovemouse )
Source(s):
http://sharepoint.asia/can-i-stop-my-screen-from-locking-due-to-inactivity/#onlymovemouse
 

DreaS

Reputable
Jan 29, 2015
1
0
4,510
0


Thanks for this info! Windows faked me out!
The Personalize page it said that the screen saver was set to "none", but I checked it's settings page anyway. There it still looked to be correct (set to none) but I clicked on the choices button (I'm not sure why) and the "apply' became available. Now I'm certain that it's really set to "none". -Drea
 

Mike T 007

Reputable
Feb 27, 2015
1
0
4,510
0
DIDN'T WORK ...already had screen saver set to "none", sleep "never" display "never". Every 20 minutes or so the screen still goes into "sleep mode" and I need to turn the power back on. Started after I added the ViewSonic VX2370 monitor via HDMI cable. Previous monitor was via HDMI cable too, but no problem

Running Windows 7 64 bit. with Intel(R) HD Graphics 4600 card, Intel i5-4460 CPU @320 GHz processor, with all the required chipsets, etc.
 

milt777

Reputable
Jun 5, 2015
5
0
4,510
0
My computer goes into sleep mode too after a couple of minutes with no activity. My screen saver is set to a specific screen saver. I tried setting it to "none" and it still goes to sleep even though the power settings say "never" when the computer is plugged in, which it was.
 

milt777

Reputable
Jun 5, 2015
5
0
4,510
0


Not a solution, just a continuation of the problem. My computer goes into sleep mode too after a couple of minutes with no activity. My screen saver was set to a specific screen saver. I tried setting it to "none" and it still goes to sleep even though the power settings say "never" when the computer is plugged in, which it was. Now what?
 
Jun 17, 2015
3
0
4,510
0




I am really happy. This solution is worked for me. I was googling one hour and finally got this is solved now. Thumps up. :)
 

Lobster70

Reputable
Jul 23, 2015
1
0
4,510
0


OK...what should be checked regarding BIOS?

I also have this problem. If I am not moving the mouse or typing for about 3 minutes, it goes to sleep. It is true sleep mode, where the system goes completely silent and upon re-awakening it, I must log back into Windows. It is definitely not just the screensaver. My IM app will always be disconnected after this event. This is my work machine, and desktop support hasn't been able to resolve. Rebooting usually will resolve it for a day, but the issue returns. I cannot find a setting that helps or explains the behavior.

I was hoping there might be a registry setting that I could check, but haven't found one yet.
 

jhnowland

Reputable
Sep 22, 2015
2
0
4,510
0


If that doesn't work , you may have a third party screensaver running like BOINC running (was my problem). I solved it by un-checking the
"On resume, display login screen" box.
 

jhnowland

Reputable
Sep 22, 2015
2
0
4,510
0
If that doesn't work , you may have a third party screensaver running like BOINC running (was my problem). I solved it by un-checking the
"On resume, display login screen" box.
 

Justincd0123

Reputable
Sep 23, 2015
2
0
4,510
0
Just throwing this out there but I havn't tested it. With the advanced power options after turning it to never sleep I seen an option stating that if your CMOS battery on the motherboard is close to going bad that it will automatically hibernate after a certain time limit, any batter at that. Maybe replace the CMOS battery for a few bucks and see if it helps since everyone is still clueless about the issue so far. I'm using an Asus ROG series with Windows 10 and I just starting getting the problem.
 

Marguerite_1

Reputable
Sep 25, 2015
4
0
4,510
0


 

Marguerite_1

Reputable
Sep 25, 2015
4
0
4,510
0
on windows 10 to stop laptop going to sleep when not using mouse or touchpad after 1min,go to personisation in control panel and type screensaver in search bar,it should be on page where screensaver is and in box put none and if the box underneath is ticked where it says display log in and on the left it says after so many mins just untick the box and click apply,this should cure the laptop or computer going to sleep.
 

Marguerite_1

Reputable
Sep 25, 2015
4
0
4,510
0
If your on windows 10 to stop laptop going to sleep when not using mouse or touchpad after 1min,go to personisation in control panel and type screensaver in search bar,it should be on page where screensaver is and in box put none and if the box underneath is ticked where it says display log in and on the left it says after so many mins just untick the box and click apply,this should cure the laptop or computer going to sleep :bounce:
 

hazardplay88

Reputable
Nov 12, 2015
1
0
4,510
0


This has not resolved for me. I have an HP 15 series (not in front of me to get exact model) laptop with a touchscreen (not sure if it's relevant, but haven't seen it yet in this thread). After about 2-3 minutes, the display will go blank. If I hit "Ctrl" on the keyboard, it will wake up, no login screen. So unchecking that box DOES get rid of that - since every other time I had to enter my pin - however; it doesn't resolve. My screensaver is set to none, and all power settings are also set to never sleep. I even went through every advanced power option I could find that even hinted at sleep or hibernate and turned it off - didn't help. Any ideas if this is update or hardware/driver related? At this point, I don't really feel like it's a setting (unless I missed something obvious I just overlooked, which happens). I only really noticed this after a string of updates went through, but I've only had the computer 3 days, and yesterday was the first day I really put it to the test.
 

gloriousfood

Reputable
Nov 15, 2015
2
0
4,510
0
I first started having this problem about 1-2 years ago. I have a Dell XPS 12 laptop, with touch screen.

It made me go crazy as I couldn't find a solution. I did all the obvious things - changing power plans so my laptop never went to sleep whether on battery or mains powered; checked settings for hibernate; checked also the screensaver even though my laptop was actually going to sleep and not simply the display going off. Eventually thanks to google I found a solution - something to do with the power management options for the USBs. So I went into the settings for the USB and for each one that had a power management tab, I set it to never try to save power by switching off and I also disabled the USB selective suspend setting. I have no idea why, but this worked.

Then, about two weeks ago, the problems of going into sleep mode restarted. I have a feeling that there is something on my Dell laptop which is conflicting with Microsoft Windows. I tried updating from windows 8.1 to 10 to see if this resolved the issue. Unfortunately, no joy there, the sleep problem is still persisting.

The event viewer yields this information:

Log Name: System
Source: Microsoft-Windows-Kernel-Power
Date: 15/11/2015 11:22:23
Event ID: 42
Task Category: (64)
Level: Information
Keywords: (70368744177664),(4)
User: N/A
Computer: Lappy
Description:
The system is entering sleep.

Sleep Reason: Application API
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
<System>
<Provider Name="Microsoft-Windows-Kernel-Power" Guid="{331C3B3A-2005-44C2-AC5E-77220C37D6B4}" />
<EventID>42</EventID>
<Version>2</Version>
<Level>4</Level>
<Task>64</Task>
<Opcode>0</Opcode>
<Keywords>0x8000400000000004</Keywords>
<TimeCreated SystemTime="2015-11-15T11:22:23.050748800Z" />
<EventRecordID>1420</EventRecordID>
<Correlation />
<Execution ProcessID="4" ThreadID="4028" />
<Channel>System</Channel>
<Computer>Lappy</Computer>
<Security />
</System>
<EventData>
<Data Name="TargetState">4</Data>
<Data Name="EffectiveState">4</Data>
<Data Name="Reason">4</Data>
<Data Name="Flags">0</Data>
</EventData>
</Event>


This is the event for each occasion. I have had no luck isolating the application that is causing the sleep problem.

I have gone into command prompt as Admin and disabled hibernate just in case that was the problem by typing powercfg.exe /hibernate off

Before anyone suggests that my laptop may be overheating, that can't be it as it goes sleep hourly. Pretty annoying when trying to watch a movie or working!!!

Does anyone have any ideas how I can prevent my laptop from continuing to go to sleep? I should add that I know very little about computers (my expertise is in the kitchen!) so any suggestions need to be written in dummy language please.
 

gloriousfood

Reputable
Nov 15, 2015
2
0
4,510
0
Ok, I think I've finally worked out the answer to my own question after a quick skim of this document:

http://www.microsoft.com/en-gb/download/details.aspx?id=26226

I'm going to post what I did in case this helps anyone else.

After typing powercfg -requests, I got:

SYSTEM:
[DRIVER]: Legal Kernel Caller

The document referenced above describes this as:

"Finally, there is a mysterious system availability request that has been set by something called Legacy Kernel caller. This is from an application that is likely using the Windows SetThreadExecutionState function to set an availability request. SetThreadExecutionState does not provide a mechanism for Windows to determine which application has made the availability request. Because of this it can be hard to determine the source of these availability requests and typically requires methodically closing applications and re-running powercfg -requests to see when the availability request is cleared. In this instance, the availability request is cleared when WMC closed, but it is not clear what its purpose is."

So I went into task manager and one by one have been ending background processes. After ending each background process, I went back into the command prompt window but kept getting the legacy kernel caller coming up....until I shut down my facial recognition software, which I purchased with my laptop from Dell. That was about 4 hours ago and my laptop has not gone to sleep since!

Hope this helps anyone else out there who's been tearing their hair out to identify their own software conflict.
 
Status
Not open for further replies.

ASK THE COMMUNITY

TRENDING THREADS