Question My core 2 duo only accepts 2gb ddr3 but if i change the cpu to a celeron it accepts 4gb and 8gb of ddr3

Sep 25, 2020
1
0
10
0
I got this samsung sff computer it has an
intel celeron e3300 2.5ghz
samsung deskTop motherboard
2gb ddr3 1333mhz
500gb hdd
240watt psu

In order for it to have at least decent performance I upgraded the cpu to an intel core 2 duo e8400 3.0ghz, when i installed the core 2 duo it worked fine with the 2gb ddr3 stick but when i added another stick of 2gb ddr3 i got a memory error beeps, I even tried inserting two 4gb ddr3 and it wont even work but when i put back the intel celeron e3300 everything worked fine, all the rams work even the 2x2gb ddr3 and the 2x4gb ddr3 and another observation is that when i put a higher end lga775 cpu like a core 2 quad the only ram it will detect is 2gb. I hope someone has answers to my problem its been bugging me for weeks. Thanks in advance
 
Last edited:
The e3300 has a 800Mhz fsb whereas the e8400 is 1333Mhz. If the motherboard doesn't properly support 1333Mhz, that's where my guess the problem is coming from.

I would also look where you are getting your quad core processors from as they could be fakes, and that can cause problems too.
 

ASK THE COMMUNITY