Question My laptop wont boot after trying to upgrade RAM on Lenovo Ideapad 330

Nov 15, 2020
3
1
15
0
Hi, I tried on upgrading RAM on my Lenovo Ideapad 330 laptop from 4GB to 8GB. Since it has only one RAM slot, I only bought one. My pre-installed RAM has specification as follows 4GB 1Rx16 PC4 -2666V- SCO-11 Samsung model, as my new one is 8GB 2Rx8 PC4-2400T-SA0-10 also Samsung. However, after I tried changing the RAM, my laptop wouldn't boot. It only powered on for around 5 seconds with no display at all and no sound was heard from the machine then it turned off completely. If I change back to my old RAM, my laptop booted succesfully. Here's what I've done

  1. Tried resetting the BIOS settings to default with the new RAM
  2. Unplugged the power cord and battery when changing the RAM, also did the 10 seconds push on the power button to discharge remaining electricity
  3. Tried unplugging CMOS battery also for 30 minutes
After doing all those, I'm still not sure why my laptop won't boot with the new RAM. Could it be that the new RAM is not compatible with my laptop? I've checked my laptop's maximum capacity with cmd prompt is 8GB, so that should be no problem. Could anybody help? My laptop is running on Win10 x64
 

Lutfij

Titan
Moderator
Welcome to the forums, newcomer!

What is the SKU for your Lenovo Ideapad 330 laptop? Might want to see if the laptop has a BIOS update pending. If it does, update the BIOS and then try the stick of ram again. Got a link to the stick of ram you purchased? Got a picture of the stick of ram you had in the laptop out of the box?
 

ASK THE COMMUNITY

Latest posts