Question My monitor does not turn on until 2nd or 3rd restart

Mercury79

Commendable
Apr 9, 2017
10
0
1,510
0
First of all sorry for my english! :)

The situation is:

I turn on my PC (with the power switch).
I get a blank screen but in the background I hear the BIOS "beep" and the Windows starts too.
Approx. after 30 sec. I hit the power switch shortly and the PC stops normally, and when I turn it on again the monitor turns on and everything goes normally.
All of the above only happen when the start is "cold" i.e. my pc hasn't been turned on for a while (15 min. or more).

I tried:
Windows reinstall
Replace the MB's battery
Change the DP cable to HDMI

Unfortunatelly the situation remains unchanged and I have no integrated graphic card on the MB or any components (VGA card, power supply or MB) to replace...

Well... does anyone have any ideas? :)
 

Mercury79

Commendable
Apr 9, 2017
10
0
1,510
0
Of course, sorry!

CPU: Ryzen 5 1600X @3600 Mhz
MB: Asrock Ab350 Gaming K4
GPU: Gigabyte GTX 1080 Xtreme Gaming
Storage: Samsung SSD 840 PRO Series & Western Digital WDC WD1002FAEX-00Z3A0 (HDD)
RAM: Kingston HyperX Predator 2x8 GB @3000 Mhz
PSU: Thermaltake Smart DPS G 600W Bronze (4 years old)
Monitor: Acer Predator Z35P
 

dotas1

Reputable
Dec 5, 2015
1,122
65
5,790
170
Do you have the latest BIOS and chipset drivers installed?
Are there more than 1 monitors plugged to the system? Can you try another one to make sure your monitor is ok?

Your PSU is a mediocre one and "might" be a problem if you also consider age degradation. I don't think it is the culprit though.
 

Mercury79

Commendable
Apr 9, 2017
10
0
1,510
0
Yes, all drivers is up to date and installed. I have a smart tv with HDMI connection and I can give it a try...
Not a monitor, but it can help resolve the source of the problem. What do you think?
 

cherry blossoms

Reputable
Apr 13, 2016
787
37
5,390
173
Turn on monitor 1st

Try disable fast booting options in Windows and in the BIOS.

With fastboot on, windows initializes I/O, then the rest as the system is loading. With fastboot off, the hardware is initialized and checked for handshaking, then the O/S boots.
 

Mercury79

Commendable
Apr 9, 2017
10
0
1,510
0
Ok, thanks for the idea, I'll try it! Otherwise I tried it withe the smart tv and
after the very first start there was picture on the tv, but not on the monitor. Maybe is this a monitor error or the graphic card's DP output error?
 

ASK THE COMMUNITY

TRENDING THREADS