Question my newly built computer won't POST

May 31, 2022
3
0
10
0
hey everyone!
here are the specs of this rig:
cpu: ryzen 5 5600G
ram: 8gb stick of 3600 mhz ram from tforce
motherboard: asrock b450M pro4-F (latest BIOS)
cpu cooler: antec a40 pro
psu: aerocool kcas 800w
case: nox hummer mc
i plugged in everything correctly cpu 8 pin atx 24 pin case cables and ssdbut when i pushed the power button nothing happened, event the case fans and the cpu cooler fans didn't spin at all
no aditional standoff
the psu doesn't seem to start
the psu does turn on when i jumpstart it (image below)
i removed the motherboard from the case and tried turning on the system outside the case
i tried resetting the CMOS
i tried jumpstarting the motherboard using a screwdriver on the power pins
the psu didn't start
but i tried something that is somewhat crazy i plugged in the atx 24 pins and the cpu 8 pin and i jumpstarted the psu while it was connected to the motherboard the cpu fan turned on for the first time the ram rgb didn't turn on and no post.
checked the cpu it's mounted properly without any bent pin
At this point, I am presuming the worst but don't want to proceed any further until I get input from others. Any help troubleshooting would be greatly appreciated.
thank you.

 
Last edited:
i don't think that the psu is the issue here since the motherboard doesn't even turn it on
Well if you've tried with just one memory stick, reseated the CPU, run it out of the case, it's probably the next place I'd be looking.

It's potentially a trash quality power supply but yet you don't want to troubleshoot it. So I'm out, maybe someone else has better ideas.
 

ASK THE COMMUNITY

TRENDING THREADS