Question My NVMe M.2 isn't being used for storage

Jun 7, 2022
40
2
35
0
My MB is an MSI MPG Gaming Plus, I have all the newest bios installed. When I go into my device manager and look it'll say the M.2 is recognized and says that it is working properly. But I still cannot use it as the actual storage, only the other SSD I have, which is SATA 2.5".

For context, it is a "CARDEA ZERO Z330 M.2 PCIe SSD" 1TB, in the top M.2 slot of the B550. I could not find a setting in the bios to enale the M.2 either.
 
Jun 7, 2022
40
2
35
0
Does it appear in Disk Management?
It does. I’ve uninstalled it and reinstalled it, I’ve expanded the components details and says it’s working but when I go to the storage tab no information displays.
When I go into the bios if I go in the tab of the pcie it won’t say anything about my m2 but when I go to test m2 failures it recognizes it’s there and says there’s nothing wrong with it
 
Jun 7, 2022
40
2
35
0
Can you show the screenshot? (from Disk Management)
(upload to imgur.com and post link)

Generally in case of a fresh/empty drive for first time use - you have to
initialize it,​
create a partition and​
format it.​
Have you done any of it?
I have not. No idea what any of that is and I can not find a video of that when I look up problems with the m2. I’ll try to upload a pic to Imgur.
 
Do you really have a sata drive in your pc?
Can you show, how it is installed in your pc? A photo?

What model sata drive?

Currently it looks like either
you don't have it,​
it is not properly installed/connected or​
it has died.​
 

egda23

Estimable
Disk Management shows a Samsung. SSD.
You say that your SATA SSD is a Samsung. SO, I suppose that this is the only SSD functioning in your PC.
The M2 is not detected and does not appear in Disk Management.
Can you try it in the other M2 connector ?
 
Jun 7, 2022
40
2
35
0
Oh wait. I see. It is my NVMe, everything is on the NVMe but i thought it was my SSD, therfore my 860 isnt showing up. I will put it in a new sata slot

Im going to have to wait til morning to fix it
 
Disk Management shows a Samsung. SSD.
You say that your SATA SSD is a Samsung. SO, I suppose that this is the only SSD functioning in your PC.
The M2 is not detected and does not appear in Disk Management.
Can you try it in the other M2 connector ?
That's just a volume label. You can make it say, whatever you want.
Ony drive present there is M.2 drive.
 
Jun 7, 2022
40
2
35
0
That's just a volume label. You can make it say, whatever you want.
Ony drive present there is M.2 drive.
Yea I get that now. I relabeled my drives so I knew which was which but I didn’t look to see which drive that was actually attached too. Now I have to figure out why my ssd isn’t working. Thank you
 

ASK THE COMMUNITY