Question My onboard LAN and PCI LAN card either both work - or both don't work??

Oct 5, 2020
2
0
10
0
Any help on this probable motherboard issue would save my sanity... unfortunately it's the worst kind of fault - random.
Maybe someone else had this problem and found a solution?

I have an ASUS PRIME B350M and after about a year the onboard LAN would sometimes not be available so I bought a PCI LAN card to circumvent, thinking the the onboard LAN was fried. This seemed to work for a little while but whether that was luck or the fault is now more random, it is now either all LAN off or all LAN on, no matter what I set in the BIOS / device manager. When not available - they are both not present in device manager (but greyed out in 'view hidden devices') and on the random working day - both adapters appear normally in device manager.
There is no specific day / time this happens - my adapters appear possibly 3 days per month on boot (random).

I installed Linux boot OS to bypass windows - no adapters present (not Windows problem)
When a laptop is wired to the router - LAN is available for that device every time (not router problem)

Attempted Fixes:
Disable / enable onboard LAN
Latest BIOS / reverted BIOS
Latest ASUS motherboard / chipset + LAN drivers
Removed battery to reset BIOS
I've tried a ton of settings when adapter is available > Power saving, speed etc

System
ASUS PRIME B350M-A
Ryzen 7 1700
32GB PC2400 Corsair Vengeance
Samsung 960 EVO NVMe + 860 SSD + other drives
Radeon 5700XT
TP Link Gigabit PCI card
Corsair CX750M PSU

Windows 10
Bitdefender Total Security
 

Lutfij

Titan
Moderator
Welcome to the forums, newcomer!

Try and work with only the onboard NIC. Can you state what BIOS version you're on currently? I'd advise on working your way up gradually to the latest as opposed to jumping onto the latest version. Which version of Windows 10 are you working with? We're currently on version 2004 and awaiting another update this year.

Make and model of your router? Does that have any firmware updates pending? How long is the Ethernet cable's length from the router to the PC?
 
Oct 5, 2020
2
0
10
0
Welcome to the forums, newcomer!

Try and work with only the onboard NIC. Can you state what BIOS version you're on currently? I'd advise on working your way up gradually to the latest as opposed to jumping onto the latest version. Which version of Windows 10 are you working with? We're currently on version 2004 and awaiting another update this year.

Make and model of your router? Does that have any firmware updates pending? How long is the Ethernet cable's length from the router to the PC?
Thanks for the reply.

I know it's not a Windows or router problem (booted from Linux with no adapters showing + other devices can use same ethernet cable with router) so I'll try the incremental BIOS update suggestion when I get some time, thanks.
 

ASK THE COMMUNITY