Question My PC crashes everytime I have the GPU in. Please Help.

Aug 8, 2019
13
0
10
0
Hi so I recently purchased a used Galax HOF GTX 980Ti, everytime I plug it into my MB it gets to the BIOs and windows repair screens, I initially thought it was a hard drive thing, but I wiped those and put a clean install and it got into windows for around 2 seconds before crashing again. Then I took out the PSU and swapped it with a RM1000i to see if it was a power issue or the other was dying but the same problem. Then I took out the GPU and realised this was my issue, as I am able to use windows fine. I then proceeded to change the PCI-E slot and I got slightly further but same thing happened as soon as I got into windows it crashed and just did the boot loop. If I could please get some help that would be greatly appreciated. I also tried resetting the BIOs and the most recent one was 2014 so I'm pretty sure it already has it and I updated the other drivers too other than of course the gpu. I really hope the GPU is not dead as that is a massive pain, but yeah any help would mean a lot. The fans don't spin on the gpu when I boot it up but the lights are on I presume this is because it isn't under load.

My Specs Are:
CPU: Intel Core i7 4770K | CPU Cooler: Noctua NH-D14
GPU: Galax GTX 980Ti HOF
Case: CM Storm Trooper
RAM: G.Skill Ripjaws 8GB DDR3
MotherBoard: Gigabyte Z87-UD3H
PSU: Corsair AX860i 80+ Platinum
HardDrive: Seagate Barracuda 2TB
SSD: Samsung 860 EVO 500GB
 

ASK THE COMMUNITY

TRENDING THREADS