[SOLVED] My PC shuts down while gaming

Tioym

Upstanding
Apr 5, 2020
302
60
290
11
As the title says, my specs are
R5 3600
B450M Bazooka
RX 570 8gb
COOLERMASTER MWE 650W 80+ Gold

I believe the problem is with my PSU because when the PC turns off, the PSU emits coil whine and usually doesn't emit any noise when its running fine or off. When the PC turns off, PSU emits coil whine and refuses to start. The things is that I've RMA'd the PSU once and the previous had a similar issue. I want to make sure the problem is PSU and not the motherboard, please help me out so I can take the mobo out of equation and just ask for a refund or get a new PSU.


Further info:
PC hasn't turned off when I'm not gaming but the problem is fairly new, I used the PSU for almost 2 weeks before this issue started.
I've built the system on my motherboard box thinking the problem was static or short in my case but that doesn't seem to be the issue.
My PSU is NOT Grounded, my house doesn't seem to have grounding sockets for the most part BUT I've talked to 2 other people who have the same PSU and have been using it without grounding and they don't seem to have any problem.
Usually when the PC crashes(with no BSOD), I have unplug the PSU from the wall and then plug it back in after 10-20 minutes otherwise it refuses to boot. It also refuses to boot atleast for 1-2 hours if I leave it plugged in the socket after a crash but I'm gonna have to test this more to see if it was just bad luck or not since I've only tried leaving it plugged once.
 

Tioym

Upstanding
Apr 5, 2020
302
60
290
11
Totally a PSU issue I believe
You were right, Switched to CV550 (Yes I know it's not the best but I'm on a tight budget after blowing money left and right)
Everything is working fine, no more coil whine and definitely no shutdowns. Don't even have to unplug and plug-in the Power cord to the PSU to turn it on after shutting it down. I'll definitely look to upgrade my PSU since I have plans for RDNA2/AMPERE Budget options. Thanks for the help!
 

dchen2105

Proper
Aug 11, 2020
192
31
120
4
You were right, Switched to CV550 (Yes I know it's not the best but I'm on a tight budget after blowing money left and right)
Everything is working fine, no more coil whine and definitely no shutdowns. Don't even have to unplug and plug-in the Power cord to the PSU to turn it on after shutting it down. I'll definitely look to upgrade my PSU since I have plans for RDNA2/AMPERE Budget options. Thanks for the help!
Good to hear!
 

ASK THE COMMUNITY

TRENDING THREADS