Question My PC turns on displays screen to log in for 4 seconds and then no display but, PC is still powered on LED lights on and fans spinning.

Feb 24, 2021
13
1
15
0
Ok, so I’m having a problem with my PC recently, it happened out of the blue. When I turn on my PC everything turns on including the fans and LED lights on ram, cpu cooler, GPU, and motherboard. The problem I’m having is when I turn it on it turns on my monitor and displays log in screen for 4 seconds and after that it freezes for 2 seconds and then no display. At first I thought it was the GPU so I sent it to EVGA and they sent me a new one but I’m still having the same issue. I used onboard display and it works fine, but when ever I’m using the GPU to display both of my monitors or at least one monitor it does the exact same thing of displaying for 4 seconds and then showing no display. Anyone know what it could be?? Also I tested it with another motherboard and the same thing happens. Is it the PSU?
 
Feb 24, 2021
13
1
15
0
full system spec? include make and model of the psu
test is bios? test in safe mode?
i7-9700k
Asus Z390-E Mobo
16Gb Corsair Vengeance RGB
NXZT X63 AIO
EVGA RTX 2070 Super XC Ultra
650W Corsair RMX 80 Gold Rating
500GB WD Nv.Me (Boot Storage)

And yes I’ve tested it on safe mode and it works but, only in safe mode when I restart and go back to normal it does the same thing
And test what on bios?
 
Last edited:
Feb 24, 2021
13
1
15
0
with the EVGA RTX 2070 Super in if you uninstall the gpu driver does it work?
could be the psu too. check the pcie power cable? modular psu. check both end
Haven’t tried without the driver but what happens if I don’t download the latest drivers? For example like games It tells me to download latest drivers. And the power cables seem fine unless I can run to micro center after work and buy one and test it out to see if that was the problem if not I’ll just return it.
 
Feb 24, 2021
13
1
15
0
if not the gpu. that left with psu or motherboard issue
Ok so I spend 4 hours yesterday doing things and ended up reinstalling windows well basically hard resetting my pc to the point where I lost all my apps and files but it’s ok I was using it for gaming not work and I think it solved the problem I downloaded very thing back and works fine now, not sure what might have caused it to turn of after displaying on screen for a little. Any idea?
 

ASK THE COMMUNITY

TRENDING THREADS