Question My sony HD-EG5 not detecting

Jul 2, 2021
2
0
10
0
whenever i connect my sony HD-EG5 hard drive to my pc it does not show in my this pc and not even in disk management. but it shows in device manager and it shows https://imageshack.com/i/pnQ63M2Qj and its properties are shown in https://imageshack.com/i/pmMXBF3yp
but when i update driver it shows no drivers to update. when i plug the hard drive into my laptop it appears in this pc. i searched too much for this and tried everything but not working.
can u pls solve my issue.
 

Lutfij

Titan
Moderator
Welcome to the forums, newcomer!

i searched too much for this and tried everything but not working.
can u pls solve my issue.
Just for the sake of relevance and not repeating what you've already tired and didn't work, what did you try before ending up here?

As for your "platforms", mind sharing the specs of both the system's that you plugged the portable HDD into? Chances are you're having an USB driver issue. Since you've dealt with a PC and a laptop, include the specs to the PC and the make and model + SKU to the laptop. If the desktop is a prebuilt, including the make and model + SKU will help and you can forgo including the specs of the build.
 
Jul 2, 2021
2
0
10
0
the automatically update feature of drivers told me to go to sony website and get drivers but i didnt got drivers and then i searched up whole web for drivers and didnt got anything then i saw youtube videos and there were videos of the same issue they told to download password protection manager and recovery tool which were given by sony on their official website and it didnt detect my sony hard drive. then i uninstalled sony drivers then i restarted my pc then also same issue then i uninstalled all usb port drivers then restarted then also didnt work then i ended up here.
i didnt understood what you are trying to tell me in second para but i just understood that you want my pc specs and usb port specs.
my usb port is 3.0
my pc specs- https://imagizer.imageshack.com/img923/3159/daBMVO.png
i also tried sd card it was also not working and it is showing its name as disk drive and i have 4 sd card all have same name
 
Last edited:

ASK THE COMMUNITY