Question My upgraded pc does not post and only gets a single blink on the CPU debugging light

Jul 1, 2020
2
0
10
0
So I had a ryzen 2600 and a 1060 but upgraded to a 3800x and a 2060.

I already updated the bios on my MSI B450i gaming plus ac so that it could support the 3800x via usb flash.
My 2600 and 2060 worked just fine before I tried changing out the cpu to the newer one.
When I took out the cpu it took a bit of force because it was stuck to the cooler which i got it unstuck with a slim knife but I did not pull out the lever of the socket.
I plugged everything in when my pc would not boot, and I only got a single flash of the light on the cpu for the debugging tool.
-note my user manual says that the cpu light means its bad or not recognized

Things I've tried:
trying one of each ram
making sure the power button cords are plugged in
trying both the 2600 and the 3800x
replugging the ssd and hdd I have
putting paperclip on cmos to short it out for 15sec without power

Ideas:
I have a feeling that the problem is that the socket broke for the amd cpu but unlike intel motherboards, the amd motherboards only have gold points, not bendable pins so I don't really know what else could be the problem.
A validation of my claim or anything to try or think about would be much appreciated :)
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS