Question Need help! Im lagging and/or disconnecting from games every 10/15 minutes.

jdraky

Distinguished
Dec 30, 2011
7
0
18,510
0
I bought a new Dream Machine a month ago. Everything started OK but since monday this week, its impossible to have a gaming sesion for more than 10 minutes without lagging or disconnecting. I tried many solutions like using CMD with refresh IP, using KillerApp, and setting a customized DNS on network adapter properties.

I Also tried updating the firmware from my DM but nothing happened. Also, i disabled External Threat Managment as for some people this was causing issues.

When i'm playing PUBG i can se that my ping is 30ms but packet loss goes above 200% (it's the only game that shows me this info.). When not playing, I'm not really sure if internet goes down as im not continuously using it. I use the method of constantly pingin thorugh console and when i lag or disconnects, i see the message "Request timed out" or "(my IP) Unreachable". I left it yesterday 1 hour without opening a game and didn't get those errors.

I'll be connecting another PC in my home as to see if the problem is my personal PC, the network or another thing.
I use a PC - Windows 10
Connected through Ethernet cable (switched 2 times to see if this was the problem)
Games i play: Dota 2, Battlefield 5, PUBG.
I have FACTORY settings on my DM. Didn't mess with those.

Does someone know what the problem could be? Any test i should run or information to bring here to diagnose?
Thanks in advance!
 

Ralston18

Titan
Moderator
Update your post to include full system hardware specs and OS information.

Look in Reliability History and Event Viewer for error codes, warnings, and event informational events that correspond with the lags and disconnects.

Run either Task Manager or Resource Monitor to observe system performance while gaming. Determine what changes when the lags and disconnects occur.

[Note: Use both Task Manager and Resource Monitor but only one at a time.]

What router do you have? The router's logs (if available and enabled) may provide some clue.

Who has full admin rights to the router? You will need help from that person.
 

jdraky

Distinguished
Dec 30, 2011
7
0
18,510
0
Hi Ralston,

I'll try to provide everything you asked for. First i want to preface all the info by stating that i've been playing for more than 40 minutes without any issues by connecting directly to the modem and restarting the PC. I'll keep playing so as to be sure (I was testing like you said with task manager open but never encountered the error). Could it be the cable? Or maybe the Dream Machine which is kind of odd as it is pretty well reviewed.

SYSTEM:
OS Name Microsoft Windows 10 Pro
Version 10.0.18363 Build 18363
Other OS Description Not Available
OS Manufacturer Microsoft Corporation
System Name DESKTOP-1O0VD02
System Manufacturer System manufacturer
System Model System Product Name
System Type x64-based PC
System SKU ASUS_MB_CNL
Processor Intel(R) Core(TM) i7-9700K CPU @ 3.60GHz, 3600 Mhz, 8 Core(s), 8 Logical Processor(s)
BIOS Version/Date American Megatrends Inc. 1005, 4/10/2019
SMBIOS Version 3.1
Embedded Controller Version 255.255
BIOS Mode UEFI
BaseBoard Manufacturer ASUSTeK COMPUTER INC.
BaseBoard Product ROG STRIX Z390-E GAMING
BaseBoard Version Rev 1.xx
Platform Role Desktop
Secure Boot State Off
PCR7 Configuration Binding Not Possible
Windows Directory C:\Windows
System Directory C:\Windows\system32
Boot Device \Device\HarddiskVolume4
Locale United States
Hardware Abstraction Layer Version = "10.0.18362.1411"
User Name DESKTOP-1O0VD02\Bob
Time Zone Argentina Standard Time
Installed Physical Memory (RAM) 32.0 GB

Using a M.2 SSD for OS and SATA SSD for gaming.
Nvidia Asus 2080.
Alienware peripherals.
Alienware Monitor 34"

RELIABILITY AND EVENTS (didn't know about these warnings/logs)

I'm havin some issue repeting every day with AMCC - Alienware Comand Center as my peripherals are Alienware. Everything else are notifications about uploading drivers from GPU, Microsoft, etc.
In the Event Viewer I see 64 errors in the last 24hs. 38 of them have DistributedCOM in the description (ID 10010) Other most common errors are Kernel-Event Tracing and Service Control Manager.
If you need me to upload LOGS or images I absolutely can.

MY ROUTER is a Unify Dream Machine and i'm the administrator. I tried connecting directly to the Modem but i get the same behaviour.

Tomorrow im connecting through my Dream MAchine (ethernet) again and test by playing. I'll look for any RECORD LOG option in my router control panel like you requested.

Thank you for your time.
 

jdraky

Distinguished
Dec 30, 2011
7
0
18,510
0
How many and what devices are connected to the mesh wifi router? What’s the mbps and are they always on?
The router is connected to MY PC (the one with the issue) and a Philips Hue HUB which is always on. Should i try without the hub? (or connecting the hub to the modem). We also have 2 iPhones and an iPad always on. 500 kbps TOPS on any of those devices. Philips Hue is 14kbps.
 

microtank

Great
Mar 26, 2021
104
6
85
0
500 kbps would need to be consistent for a game like gears of war 4. But ya the dream machine is probably running on 5 ghz. Which means it has a short distance, especially if it’s AC. If you have a decent old router you can put the DM closer to the other DM device and use the older router as a access point, AP & WDS, or just wds which in WDS mode would only basically make it a wireless receiver and not granting other devices on the older router any wireless access, but would make the lab ports open to physical Ethernet cables. There could be a number of things going on. But it depends on the mbps you are paying for. And since AC 5 ghz capable devices like a cell phone or a smart TV can easily use 1000 mbps, then that could be a issue. But it might be reception as well. If anything you want the computer to have a wireless router with a 5 dbi antenna or 3 or 4 of them hoping at least 2 of them are 2.4 ghz. But in all honesty it could be a number of things. But from what I’m seeing a PC user that games a lot would “want” 9 mbps. Or maybe 10, depending how desperate you think you need a fast file. Get tastyspleen’s quake 2 download. It’s easy to install just point and click, comes with mods such as a server list, pick a server, and see if it functions without lag or hardware problems. In all honesty I’d have troubles with quake 2 online then 33.6 kbps won’t save you and that’s slower than 56 kbps. I ran the tests. Also ping the servers IP address in command prompt a couple of times and see what’s going on to see if it’s strictly internet. I’m sorry but old games provide a wealth of information and you should see if that works out. Plus with a cellphone, 4G or 5G you can switch between those 2 and check the mbps to see if it’s even hardware or a OS issue. 4G for me gets full signal, and 5G gets around 75 percent. However 4G for me struggles on upload speed, so used 5G. Use it has a test, if you have mobile hotspot data, I have iPhone so I just turn hotspot on and plug it into a USB port and icon tells me my PC is online. No adapters, no routers, purely the phone. If it’s not the phone it will be the Dream Machine, or your modem, and if your modem is broadcasting wifi that’s another thing to try to turn off. But odds are it’s, signal strength, bandwidth, or hardware. But if o can run 7 devices on 6 mbps with no issues, until I ran into hardware limitations, then you can accomplish a lot. Plus, you might want to look into QoS on your Dream Machine, and issue bandwidth limits per device connected to it.. but if you view a video off the internet in 4K, chances are you can kiss 18 to 25 mbps goodbye. Anything is overkill above 1080p and to me 720p should be your max unless you are looking at microscopic details. There’s so many things that could be going on, including the PC automatic software updates and a bunch of other things. But I’m only using 2.048 mbps on my phone right now to write to you. The only issue I’ve seen is that Amazon may not have a video resolution auto adjuster on the app, which is causing delays or the app is not working properly on my iPhone. I’ve played Starcraft 2 on pure stable kbps, on 1v1 on Starcraft 2, knowing 4v4 needs a little bit more to function properly. Test the modem, everything. You have to make sure one device is on the entire network first to get accurate reading, cause it can also be the ISP or the modem. And since this household doesn’t let me configure anything. I took matters into my own hands, ditched a 50 dollar usb AC adapter, even figuring out by default it was in AC mode. Which in turn constantly gave me disconnects, and no internet at all. If in wireless N 2.4 ghz, you still probably want half the distance it can do, so this would probably go for AC. But meh, if you don’t have a old router, you can find some certain year older models for 20 bucks, with multiple Ethernet ports. My room is in the opposite end of the house, and modem is half way point, but blocked by a massive fireplace, and has glass shield right above, the modem/wifi piece of crap is also barely a foot above ground, then we have 3 mesh pods, and I tried everything without configuring any of the equipment.

everything is a mess here for 300 mbps. I can get up to 40, but with I got set up, the wireless n router is my main source of internet, and I can get full signal anywhere in the house. But I only use about 6 mbps by force. I’m one person, but 4K is still not better than progressive scan, and massive files of even 5 gigs will easily cause problems, especially on a PC or a device that can use all bandwidth for a 1 gigabyte download. Add 32 devices and you wonder why I’m cranky, with 300 mbps and 5 of those devices are 4K security cameras in HD, and we got a Mac on standby 24/7 that no one is using. And then still blame me, when in reality I won’t allow my equipment to even exceed 1.33 percent of what we are paying for. Your ping will not be affected if know what your doing. Ping is really a indicator of how long it takes for a radio wave to reach the target server. Fiber, satellite starlink, cable, dsl, 4G... if I can use a legit ISP and dial up modem, for quake 3 arena and get 70 to 90 ping, then 21 years ago I knew what the hell I was doing
 

Ralston18

Titan
Moderator
This:

"In the Event Viewer I see 64 errors in the last 24hs. 38 of them have DistributedCOM in the description (ID 10010) Other most common errors are Kernel-Event Tracing and Service Control Manager "

Corrupted files perhaps.

What you can do:

Try running "sfc /scannow" and "dism" via the Command Prompt.

References:

https://www.lifewire.com/how-to-use-sfc-scannow-to-repair-windows-system-files-2626161

https://www.howtogeek.com/222532/how-to-repair-corrupted-windows-system-files-with-the-sfc-and-dism-commands/
 

ASK THE COMMUNITY

TRENDING THREADS