Question Need help in installing OS in my old windows tablet (Having a hard time installing via boot thru USB)

Sep 14, 2020
9
0
10
0
Hi I have an old OEM windows tablet that has a pre-installed windows 8.1 back when I first bought this. the specs are:

  • Intel Atom Z3735F Baytrail-T processor, 1.8 GHz Quad Core with Hyper-Threading Technology
  • Intel HD Graphics Gen 7
  • 2GB DDR3L RAM
  • 10.1-inch Multitouch Capacitive Screen with In-Plane Switching (IPS); 1280 x 800 resolution
  • 32GB storage, expandable via MicroSD up to 64GB Expansion
  • 5-megapixel rear camera
  • 2-megapixel front camera
  • WiFi, Bluetooth, mini HDMI
  • 7500mAh Li-Ion battery
  • Windows 8.1 with free 1-year subscription to Office 365
A few years ago I upgraded from windows 8.1 to windows 10.

now come 2020 I wanted to install new lightweight OS on this to give my old windows tablet a new life.

I installed CloudReady OS and set my tablet to boot via USB in next restart via windows 10.

The tablet booted up CloudReady OS and I installed it but it keeps getting error when I am installing.

Now here is my problem.
  1. I can no longer go back to windows 10
  2. I tried installing other OS (including windows 10) but it does not boot it is only stuck at the manufacturer's logo
  3. I can still boot from CloudReady OS but it does not let me install the OS, it just allows me to boot the OS via USB
Thanks in advance. I have tried researching my best on possible ways but most guides I see are the usual booting process

Edit:
Model: Starmobile Engage 10 pro (Manufacturer is no longer active and I cant contact customer support)
CloudReady OS installer creates its own bootable USB
for other OS I've tried. I used Rufus
 

ASK THE COMMUNITY